XOD IDE 0.25.3 crashes on "Deploy-upload To Arduino" Windows 10-64


I am new and I just installed XOD on Desktop Windows 10 - 64.

When following tutorial 02-Deploy and lauching “upload to arduino”, XOD opens the dialog to select my board model attached… and crashes !!! :frowning:

I tried to reinstall, disconect board… no joy !!

Any idea to send me in the right direction?
Anybody with same experience?



Hi, there is a small delay where you load the board list, maybe it’s just that?

The list doesn’t show up… the application just crashes…

When I had problems at the beginning use the “everything search” application, and delete all the XOD folders, and then “TrashReg Freeware” to delete registry keys, it could work for you too

I uninstall XOD, removed everything, clean registry, reinstall XOD 0.25.3 and still it crashes when deploying and upload to arduino.

I can’t even select the board… :frowning:

That’s weird. When you cleaned up the installation, have you removed C:\Users\You\xod as well? If not, try to delete just C:\Users\You\xod\__packages__ and try again. Also, hit File → Switch Workspace and make sure it points to C:\Users\You\xod.

If nothing helps, could you run XOD IDE from cmd.exe so that we can see stdout of the process crashed? It can contain important details.


Tks for the help…

I tried all solutions in your first paragraph, but no better…
The program loads ok, I can select the tutorial sketch, but when trying to upload… CRASH…
It takes a few seconds to crash … as it tries to load the board list and it feels like it is running out of memory…

test, menu > deploy > Upgrade Packages and Toolchains

Did that too… “All packages are up to date”

That’s really weird, so I propose to try two things:

  1. That @nkrkv already asked, to run XOD IDE from cmd.exe:
    1.1. Press Win+R, type “cmd”, press Enter
    1.2. Then type in quotes: "C:\Program Files\XOD IDE\XOD IDE.exe", press enter
    1.3. Reproduce the bug. Probably you get an error in the terminal window. So then copy-paste it here and we’ll inspect the error.
  2. Probably you get caught a bug in arduino-cli that was fixed after out latest release. So you can try to update it manually:
    2.1. Download latest version of arduino-cli from here: https://downloads.arduino.cc/arduino-cli/arduino-cli-latest-windows.zip
    2.2. Unpack it and rename exe file in arduino-cli.exe
    2.3. Make a backup of already installed arduino-cli, just rename it: C:\Program Files\XOD IDE\resources\arduino-cli.exe
    2.3. Copy new one into the same folder (C:\Program Files\XOD IDE\resources\)
    2.4. Try to reproduce the bug

If something helps (or not), let us know.

1 Like

[14:53:57.826] [info] Checking for update
[14:54:00.885] [info] Update for version 0.25.3 is not available (latest version: 0.25.3, downgrade is disallowed).

that is it !!
nothing is coming in the cmd window when the program crashes.

I did after second part and updated arduino-cli and still yields same crashing result:
-Opening normally
-Opening through cmd

after a few second (22 to be precise) XOD IDE closes

No board connect? no work

I am using an Elegoo UNO R3

I tried also by disconecting the board, but same error

you could do a screenshot of in configuration - device manager to see the ports?

here it is…

the board is on COM 4
I have no issue with Arduino IDE

Could you temporarily disable other ports leaving only COM4 and try?
the message “Enumerating…” can be an indication of the problem …


Same result…
I evn disconected all devices… :frowning:

It’s very weird, I could assure you that’s why …:confused:
still showing “enumerating”?

It probably one of the 2 things : when it builds the list of board or when it is enumarating the ports…
After few seconds (15-20) it crashes just like it is running out of memory.
I tried to increase also the size of virtual memory to 4500 min with a max of 9500 to see if this would help, but still it crashes…