Trying to publish a lib or a bug maybe?

i made a node to read 1,2K I2C eeprom then i tested and tried to publish it then after saving the project i noticed i couldn’t open the xodball so i looked at the pulished lib and it wasn’t working so i made the same in a new file then saved and published it again and it was the same but this time the saved xodball was working so i unlisted the two libs and here i am asking what i did wrong or is this is a bug
and one more question is thare a way to delete a lib i published i can only see unlist

I could be wrong, but I don’t think you can push a library from a xodball. I think you have to save your project in the older format.

thanks for the reply i did try this one for my third try

and it did the same as the second picture but the file itself works fine is this the old format i am new to xod ?

Yes, the Multifile XOD project format you show above is the “older format”. Sorry I was so vague…I wasn’t at my computer to check at the time, but there are only the two formats.

I assume you have your project open that you want to publish, then you select File > Publish Library… In the next window you need to edit to set a version number (a description should also be added), then you can Publish. I was able to re-publish one of my libraries (but that might use different code on the server than publishing a new library). I do not see your eeprom library on the site when I do a search. Did you configure it as a private/hidden library? Maybe there is a website issue giving you access to your own private libraries? I get the same internal error when I try to access the URL for your library, but I get “library not found” if I change the URL slightly to make it invalid. This would seem to indicate a problem that the library now “sort-of” exists; which may be a problem caused by pushing a xodball for the library initially (or that might be a valid option now & I’m just chasing shadows…)

I’m guessing you will need a site admin to help you resolve the problem with this library. As a work-around, you could rename your project & retry publishing it as a new library.

thanks for the reply and the help
the first one is the multi file format /old
the second one was two xodball first one not working after saving the second one works
the third was a xodball and the first one i tried to publish
and i Enlisted them for testing

from what i understand that after uploading the first and second ones as xodball something got sad
right so the third one didn’t work as a result
how to get ahold of an administrator ?

Developers usually monitor this forum, but I don’t think they check as regularly as they used to, so it might take a while for them to respond. @nkrkv, is this something you can help with or direct to the appropriate person? Can library be changed to not allow push of xodball if that causes problems?

1 Like

thanks for the active help

Hello! The devs are looking into the problem. The file published indeed contains some inconsistent data and we’re trying to understand how it ever could happen.

What I can say almost for sure is that the format in which a project is stored locally (single xodball vs multiple files) cannot affect the result of the library publishing.

Stay tuned and thank you for sharing the problem :wink:

1 Like

Hello, @gamer24
Thanks for the report.
Can you upload a xodball of this project? It might help us in investigating the bug.
here you go thanks for the help


I have a quick solution for you right now:

  1. Open YOUR_WORKSPACE/__lib__/gamer24 directory and rename the EEEPROM-256-Read directory with lowercase: eeeprom-256-read.
  2. Now you can open your project and save it as a valid xodball.
  3. Also you can publish the library now.

The problem is that uppercase is not valid for patch paths, but your project directory has uppercase. So it does not appear in the project browser, but it saved in the xodball. So it corrupts the xodball.

It is definitely the bug and we’ll fix it soon.

1 Like

thanks for all the help
it works

1 Like

You’re welcome.
I’ve just created an issue: XOD IDE loads libraries with invalid patch paths · Issue #2097 · xodio/xod · GitHub

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.