Upload Libraries

Hello Everyone I tried to upload a library just few mins ago but I got the Service unavailable message error!
Anyone know why?
Thank you all!


XOD is active and that’s definitely a problem. Where do you see the error? In the snack bar inside IDE when you’re doing File → Publish Library? A few more questions:

  • Are you logged in inside IDE? (hit View → Account Pane)
  • Can you install others’ libraries?
  • Can you open https://pm.xod.io/swagger in your browser?


So, Yes I see the error when doing Publish Library

  • Im 100% logged inside before publish it
  • I already installed other libraries
  • When I open that link this is the result I get:

Spotted a problem on our backend. Your user account was not replicated across microservices as it should. All new users since a particular (not yet known) date are affected. We’re looking for a solution. We have no back-end developer right now in our team, so it’s hard. Please, be patient.

Meanwhile, all new users since the current moment should be able to publish fine.

Thanks for the report.

OK, so what should I do until that?
And how much time should I wait?
Thank you

If you register a new account, you should be able to publish immediately.

I’ll try to find a fix for existing users in next two days.

Well, I tried to make a new account and I got the same error!
Service unavailable

I’m able to re-publish an existing library. I have not tried to create a new library.

Could explain how can I republish a library?

Whew, seems like I fixed the problem. Publication should work again for all users. Please, try again.

1 Like

You republish a library the same way you create a new one, you just have to bump the version number, or you get an error that the library/version already exists.

Suppa dev!!!
Upload 100% working thank you for patch this in 0 time

OK I publish my library and now I want to ask you something that I cant do.
I need to put a 0x3F hex value into a function but in XOD seems not to be a type that can hold this hex!
I tried using a string and then convert to int but It doesnt work!
Any suggestion?
Thank you!

Use your favorite search engine to find a hex->dec conversion calculator. Convert 0x3F from hex to decimal, and use the decimal value in XOD.

(0x3F would be 3*16 + 15 = 63 in decimal)

1 Like

Glad you succeed.

Hex issue is another issue, you had to start another thread… At that moment you would see the question has been answered for many times. Well, @gweimer did it again :wink:

So, I’m about to close the current thread as it’s topic has been exhausted.

Mmmhhh. It totally works!
There is already a hex>dec convert in xod?
I want to improve a library