Missing items in core

hi guys,
i just started the program,cant find the digital Input to make a push button, also for example analog input is missing, seems to be many items are missing

Most likely, you are looking in the wrong section. If you have an idea what you are looking for, the easiest way to find it is with the search function. Double-click in the workspace, then type string you want to search for, “digital”, “analog”, “read”, etc. (without the quotes). Any matching nodes will be displayed and you can select the one you want.

i was following this video, he just got a digital input( push button) from core,i even tried the search bar it didnt find any digital input or switch or button, i tried the lower version,but still the same… min 2:30

Many of the nodes were moved to new folders during updates, so the location of nodes may have changed. That wouldn’t explain why search doesn’t find them, though…

Usually problems with XOD built-in nodes is due to changing one of the nodes and saving it. This creates a custom copy of XOD nodes so you don’t get future updates. That also wouldn’t explain why built-in nodes are gone, though.

Before you start typing search string, the search box displays “Search nodes”? If not, you may be trying to Add Library or some other search that won’t find nodes.

yes,the search box displays “Search nodes, then maybe the name changed to (digital read) instead of (digital input ) ? or if its been there then they decided to use only read instead of input ?

It’s been digital-read as long as I can remember. -input and -output are used for pin types.

well, yea it worked for the digital read , just the name in the video was different, i googled for (xod push button ) and it showed digital read, i learned the digital read command before in the IDE… thnx for your support

hi, as i recommend gweimer use the search … by pressing the “i” key and type hardware and you will see button, mechanical-switch, etc.

XOD is constantly changing, just like libraries … tutorials may be out of date.

When you open xod in the central message there is a link that opens the examples of the built-in tutorial.

If you hover the mouse cursor over the node, in a pop up it will tell you which library it belongs to.