Invalid xodball format

i’M getting this error. Program runs fine. But when I save it, and exit XOD.
Then late come back and reload the project I get this error. Since I’m totally new to this wonerful
program, I assume I’ve done something wrong. HELP.

in the library folder there may be a folder with an invalid name … note that only lowercase letter and middle sign without spaces are allowed

Hi, @donald-emerson
Can you please attach this xodball file.
In similar cases, it is not XOD fault. It seems to be an error of the file system of the computer OS (maybe the computer was not correctly powered off while XOD was running or other reasons).
In any case, you’d better show us the defective file.

Thank you for your help. As requested please find one of the files attached to this email.
Any input on this issue would be greatly appreciated.

Sensor-SSD1306-BARGRAPH-V3.xodball (209 KB)

Here it is.
Sensor-SSD1306-BARGRAPH-V3-fixed.xodball (50.9 KB)
The Storage/bradzilla84/ should be storage/bradzilla84/
In a fact, we don 't quite understand how you managed to change the JSON patch like this. This could done only manually =) Seems to be a bug.

Is it opening now?

Thank you, that worked. I’m very new to this way of programming, and quite frankly been out of this field for a very long time.
I am curious about this “storage/bradzilla84/” where did you find this? Not familiar with this.

I did some slight modifications to the program and saved it. I then exited XOD, Reopened XOD and loaded

the program and the same error. I gotta be doing something wrong… Somehow when I save it something is going amok.

Also notice this screen shot of whats in “My Project”. When I was first using XOD I don’t remember all these additional patches. Just had the “main”. By the way I have twice uninstalled XOD and reinstalled XOD hoping that might help.


Sorry for all this really want XOD to work for me.

Appreciate your help very much.

Sensor-SSD1306-BARGRAPH-V3-fixed.xodball (209 KB)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.