I broke XOD with help from my son


#1

I was having fun learning XOD. I had leds blinking and pots controlling servos.

My precocious 6 year old son was having fun too.

Now I can’t even transpile a single led XOD. This is what I get:

· Transpiling…
Patch @/main contains dead references:
Specified node types haven’t required pins for creating links
Fix or delete them to continue.

I have uninstalled XOD and reinstalled with no change. So either, how do I fix this, or how do I do a thorough nuke and reinstall?

Thanks,
Peter


#2

Have you tried just creating a new project and just adding a single LED node? If that works, then your son has probably deleted a node or made some other change to the single project and not affected the entire installation.

If that doesn’t work, I would look in the folder where your XOD projects have been saved. Does it have a __lib__ folder? If so, what is inside that folder? If there is a xod folder inside, close your XOD application and rename that folder to xod.bkp and try running XOD again. If it works now, you can delete the xod.bkp folder; it is a broken copy of the built-in libraries.


#3

The error means you have a node of a patch that does not exist or was deleted. This should be easy to fix, but a bit more details are required:

  • Do you see anything marked with exlamation points in the Project Browser pane?
  • Do you have a node marked with red outline on your patch?
  • As @gweimer asked, do you have C:\Users\<name>\xod\__lib__\xod on the file system?

#4

Renaming __lib__ fixed it!

Thank you.

How do you display the lib dir name in the forum? I just get bold.


#5

Type it out, then highlight it and click the </> icon for preformatted text at the top of the reply window (or just put back-ticks around the text).


#6

Thanks, I edited in place with your help.