Error: exit status 1. (Uart-0 node. Uno R4 Minima)

I have a normal USB-C cable from the computer to the microcontroller. where I want to test if I can send data from the APP Inventor emulator to the microcontroller.

But I get an error when uploading.

The plan is to use a tablet to send data via OTG-USB.

Microcontroller: Arduino Uno R4 Minima

Program in XOD:

But when I upload I get this error code:

Begin compiling code for the board Arduino UNO R4 Minima :package:

C:\Users\kp-sp\AppData\Local\Temp\xod_temp_sketchbookmO6LKl\xod_1701694458288_sketch\xod_1701694458288_sketch.ino: In member function ‘void xod::xod__uart__uart::Node::evaluate(xod::xod__uart__uart::Node::Context)’:
C:\Users\kp-sp\AppData\Local\Temp\xod_temp_sketchbookmO6LKl\xod_1701694458288_sketch\xod_1701694458288_sketch.ino:1095:27: error: ‘SERIAL_PORT_HARDWARE’ was not declared in this scope

C:\Users\kp-sp\AppData\Local\Temp\xod_temp_sketchbookmO6LKl\xod_1701694458288_sketch\xod_1701694458288_sketch.ino:1095:27: note: suggested alternative: ‘SERIAL_PARITY_MARK’

Error during build: exit status 1

Same error code if I instead uses SOFT-UART(D0=RX and D1=TX) /UART0-1 -Nodes…

Here is some information about USB/UART:


I have tried googling my way to a solution. but I haven’t found anything that made sense.

Hope someone can help

thanks in advance

I have tried to make a very simple code.

Which still fails:

The full error messags:
Begin compiling code for the board Arduino UNO R4 Minima :package:

C:\Users\kp-sp\AppData\Local\Temp\xod_temp_sketchbookSQVor2\xod_1701705940826_sketch\xod_1701705940826_sketch.ino: In member function ‘void xod::xod__gpio__digital_write::Node<constant_input_PORT>::evaluate(xod::xod__gpio__digital_write::Node<constant_input_PORT>::Context)’:
C:\Users\kp-sp\AppData\Local\Temp\xod_temp_sketchbookSQVor2\xod_1701705940826_sketch\xod_1701705940826_sketch.ino:1290:48: error: cannot convert ‘const bool’ to ‘PinStatus’ for argument ‘2’ to ‘void digitalWrite(pin_size_t, PinStatus)’
::digitalWrite(constant_input_PORT, val);

Error during build: exit status 1

Is Arduino R4 Minima not compatible with XOD?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.