Arduino uno R4 minima

Hi there.
Just got Arduino uno R4 minima. There is problem with output ports, they are react together. D2&D11, D3&D12, D10&D13 is affected each other. I have to try with IDE port by port and was working fine.
Thank you wery much for help.

There is another problem with Uno R4 minima.

Uploading: blad kompilacji.jpg…
The same error in Arduino Uno R4

Today , different info

Uploading compiled code to the board…
Performing 1200-bps touch reset on serial port COM7

“D:!\Arduino\Xod_packages_\packages\arduino\tools\bossac\1.9.1-arduino5/bossac” -d --port=COM7 -U -e -w “C:\Users\darro\AppData\Local\Temp\xod_temp_sketchbookOPth2Q\xod_1712359639495_sketch\build\arduino.renesas_uno.unor4wifi/xod_1712359639495_sketch.ino.bin” -R

No device found on COM7

Set binary mode
Send auto-baud
Set binary mode

Error during Upload: uploading error: uploading error: exit status 1
Upload failed
Command Process exited with code 1
Make sure the board is connected, the cable is working, the board model set correctly, the upload port belongs to the board, the board drivers are installed, the upload options (if any) match your board specs.
At the Arduino IDE works good on the port COM7

I had a similar issue with the R4 wifi, I think the most likely cause of this error is that trying to compile code that is meant for an AVR-based Arduino board (like Uno, Nano) on a board that uses a different architecture, such as ARM. When I connected the R3 uno, it compiled, uploaded and worked great but would not compile for the R4. Just throwing it out there as this is what I came across. Also had to make sure my cable was a data cable and not just a charge cable, some USB-C only charge.

XOD is using AVR-tools to do the compiling, so it is unlikely to work with boards not using AVR

I have been thinking is somethink like this You say, but. How that come: all nodes are working /RTC, Dislays, key boards atc atc, just DIGITAL WRITE is not working at all, but LED node is working in nonproper way /ports are affecting each other/
THNKS for any suggestion.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.