Debugging don't work on macbook

I installed XOD on my macbook pro 2018 and created simple project with LED. Uploaded it on board Iskra Neo and all works good. Board connect with mac via cable from box and adapter USB to USB-C ( RA-OTG1). I added node “Watch” and launched “Upload and Debug”. And node “Watch” still show “watch” and don’t show 1.00. I try it in “Simulate mode” and it work correct.

Can anybody help to solve the problem?

1 Like

Try pushing reset button on the board after download had completed. Sometimes XOD doesn’t start listening soon enough after download and debug info is lost.

I tried this but it didn’t work.

Which board have you selected? from what I see his badge is like arduino Leonardo (ATmega32U4)

This board https://amperka.ru/product/iskra-neo

Interesting. We’ve just recently fixed a problem with debugging Leonardos(and Iskra Neos), the fix was released in v0.30.0.

My MacBook has good old usb type a ports, but I will try to get my hands on a setup similar to yours and test it.
Meanwhile, if you have another adapter, please try it and report the results.

I tried to connect the board to all ports on my mac. And one time debug was worked well (I saw realtime data from pot) but I can’t repeat it again. Also when debug don’t work STOP btn don’t work too when I press it nothing happens. I use “close debug tab” for stop debug mode.

Now I haven’t other adapters or cables. This adapter USB - USB C I use for connect my android phone with mac and it work well.

1 Like