Arduino COM port not found (Windows and Linux)


I tried XOD (v0.11.0), and the ‘Upload to Arduino’ feature does not work: it can find the Arduino Uno board connected to the computer (‘Serial port’ input field says ‘No connected boards found’, even after hiting the ‘refresh’ button).

I tried with different boards.
I tried on different computers, with Windows 10 v1703 or Linux (Mint 18 ubuntu based distribution).
I tried running XOD as administrator privileges, in both Windows and Linux.

No success at all.

The boards are reconized by each testing computers (Arduino IDE can use them and upload things).

By the way, using electron for this kind of software is a really bad idea: electron is a performance killer (need high end computer with GPU acceleration, does not work well through remote desktop). Most of the targeted peoples (beginners) will try to run it on small computer or laptop and will be disappointed by the slowness of the app.

I tried it on an Asus transformer pad (which however can run some little games) and it runs horribly.
I also tried it on the computed of my electronic lab, an old good eeepc box running linux, and XOD take more then an minute just to start (Arduino IDE and other development labs start in a dozen of seconds and runs well).

Aside of that, this software looks promising, not only for beginners or people that does not know programmation, but also for experienced guys needing to run very quickly a simple task for tests. Hopes I’ll be able to test it once it works better.

1 Like

I have the same problem, running Linux Mint 18.2 “Sonya”.
Tried it with multiple boards, they list correctly (terminal command “lsusb”) and I can program them through PlatformIO without a problem. So it seems a XOD issue.

1 Like

i have same p[roblem,shame i think this could be a great aid

Hmmm… That’s strange. Definitely looks like a XOD issue although we haven’t seen any problems in port enumeration on all three OS’es. Will investigate the bug tomorrow.

@articcynda Am I right, you saw ports when you had the previous version (v0.10.1) installed, and now they disappeared?

@nkrkv That’s correct, in v.0.10.1 the enumerator worked correctly, but in the current version it doesn’t detect devices anymore. I checked it with different USB to UART controllers (FT232 on Sparkfun ESP32 Thing, CH340 on NodeMCU, and the Atmega16U2 used as USB to UART bridge on Arduino Uno), and none show up in XOD. However, they all list correctly in /sys/class/tty, and PlatformIO is able to program the boards normally.

It may be useful to know that FT232 and CH340 enumerate as ttyUSBx while the Atmega16U2 enumerates as ttyACMx and neither show up, so it can’t be a filter issue. What else changed on the device enumeration code between the two versions?

I’m having the same issue. OSX 10.12.5, 2011 MacBook Pro.

Confirm. We’ve found the problem. It is because the module which should enumerate serial ports was improperly built.

We missed the problem because it happened on the very last stage when the distributives were packaged. Our dev-versions were not affected.

Thank you all for the report. We’ll release a new version of XOD IDE in few days and this bug will be fixed there.

The bug has been addressed in v0.12.0


I confirm it works now with v0.12.0, on a Windows 10 machine (didn’t had time to test linux for now).
The port can be selected, and the program compile and upload quickly.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.