XOD IDE Problem Solved ( FIXED )

#1

The problem I have been having with the DHT-11 and DHT-22 not reading but now it works !
It DOES NOT WORK with version ( Latest version This is v0.29.1(2019-04-18)

But DOES work fine with v0.19.2(2018-03-12) <-- That is 24 versions EARLIER.

To see all the problems I had previously, please look at my posts on the DHT not working

On this version of XOD the start pulse is 15 ms wide. Maybe the 50 ms is too wide and overwriting the date coming back from the DHT ? SO it may look like the DHT doesn’t really care how long the start pulse is…

My best guess of the reason that the new version did not work is it is NOT SWITCHING the port from output to an input, maybe not fast enough or possibly not at all.

All this time an hair pulling due to the new versions not reading the DHT series.
It looks like now I will have to join the “Hair Club for Men”
Dave

#2

UPDATE,
Hello All. This BUG was already reported on GITHUB !
If I would have known it would have saved me so much time.
SO, if you have a problem, look into GITHUB first before you post your problem on this forum.
If I had known to look there first !..