XOD 0.20.1 issue


#1

I was trying to look at how one might create a queue node with push/pop pulses. I only got as far as input-t1, output-t1, two pulse nodes & a buffer. Then I tried to add a variadic, and the entire IDE window went white except for the File, Edit, Deploy menu at the top.

I can attach the project as a zip file, but I’m assuming this is enough to replicate the issue. I tried loading the project in v0.19.2 and it complains that variadic needs an output (old version doesn’t recognize output-t1 as an output).

Replacing input-t1 & output-t1 with input/output-number still banks the window when variadic node is added.

I think it took me <10 minutes to break the new version :slight_smile:


#2

:open_mouth: That’s a critical bug. However, I can’t reproduce it. Here are the steps:

  1. Place a input-t1 node
  2. Place a output-t1 node
  3. Place a input-pulse node
  4. Place a output-pulse node
  5. Place a buffer node
  6. Place a variadic-1 node

And it does not break IDE. I think I missed something. Would you help? A shortest reproducible scenario will help us a lot.


#3

Thanks!
Successfully reproduced it, the fix is on the way: https://github.com/xodio/xod/pull/1194


#4

v0.20.2 is out!
Let’s see how long it takes to break😉


#5

A lot less time to break it this time…it can’t open__lib__/gweimer/utils/utils-example-queue/patch.xodp and keeps asking me for a new project space, so I’m unable to open any of my projects or even see the default project screen. I get the same error with 0.20.1, but it works fine with 0.19.2. This is the same version of gweimer/utils that I published.

If I switch my workspace so it is not trying to load the library, I get the default project page and can load other projects, but I still can’t open the utils project.

It would be a lot easier to read/copy the error message if it displayed for more than a few seconds before going away…


#6

OK, the problem is at least partially my fault. gweimer/utils v0.0.12 included a node from xod_bkp library that only exists on my box. Once I replaced that with a valid xod node equivalent, I can now load using XOD v0.20.2 and gweimer/utils v0.0.13.

Not sure why xod_bkp node was causing a problem on my box that would have had that node, though…


#7

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.