XOD 0.31.0 released: Standard Library Improvements

5 Likes

I opened up XOD ide but it never offered me an update. Is there a way to manually start the update inside XOD ide? I don’t see anything in the menu system for updating the XOD software. Under help it says I have version 0.30.0

Are you on Linux? The Linux version lacks auto-update.

Regardless of the OS you can download a new version and just install it over the existing one.

Okay that explains it. Yeah I’m on linux.

Hello

I had problems compiling a program after the installation of the new version and i fount that the error is caused by a defer node if it’s used for a cycle; for example, to reset a counter if it reaches a certain number.
I reinstalled version 0.30.1 and tried the same program and it works.

This is the test program i made. Is it a bug of the new version?
Defer Test.xodball (2.6 KB)

I have also a problem whit 0.31.0 whit the Led ,after reinstalling 0.30.1 the problem is solved.
The message i got
Dead reference Error
Path "xod/core/act"is not found in the project.

it appears only in the IDE version of 0.31.0 the online version is OK

Looks like you have a stale standard library fork. Delete $HOME/xod/__lib__/xod and $HOME/xod/__lib__/xod-dev, restart IDE, and try again.

Yep, that’s a bug. Will release a fix very soon.

1 Like

@soulbringer, the fix is released. Please update to 0.31.1

2 Likes

Even with the update i got the same problem using WIndows 10 Ide version 0.31.1
eror path “xod/core/act”’ not found

Greetings Wim

It’s very likely that you have a personal fork of xod/core from 0.30 which overrides the 0.31.1. Hit File → Switch Workspace. What directory do you see here? In this directory, delete ./__lib__/xod with your file browser.

THX it works i just removed that specifiek map and installed the latest version

New problem in Xod/Core/ Equal

delete equal or in the project browser select the type (number, etc)

there is a node with no connection there

Another bug? Someone pointed out gweimer/utils/running-avg no longer works. I assumed something had changed with update & there were errors with it somewhere, but it seems to be OK.

Trying to use it in a patch, nothing seems to update. Since it is built on gweimer/utils/queue-buffer, I tried testing it. In a patch by itself, it works fine. If I add running-avg to the same patch, it no longer updates

image

Pulsing queue-buffer-UPD should update MEM output to match queue-buffer-NEW input. Pulsing again updates oMEM to match…except nothing happens in the patch above unless you delete the running-avg node, then queue-buffer works correctly.

How does having an unused patch (with no timers or other interrupts) affect a patch that only uses select, defer, and buffer nodes?

queue-buffer node:

I was able to reproduce this bug, but only during simulation. Still investigating why this is happening.

Did you test it in simulation mode or on an a real board?

1 Like

Simulation… I was too lazy to dig out my board