Welcome to zod not working

Hi all, I am brand spanking new to ZOD and electronics in general, and trying to make stuff with small motors.

This is the error code I get while trying to follow along. Has this happened to anyone else? I think I have everything installed properly on my computer.

The generated C++ code contains errors. It can be due to a bad node implementation
or if your board is not compatible with XOD runtime code. The original compiler error
message is above. Fix C++ errors to continue. If you believe it is a bug, report the
problem to XOD developers.

If you are trying to run as a simulation, that is a problem with the server doing simulation builds. We are hoping developers will be fixing it soon.

Looks like simulation has been fixed.

Thank you for letting me know :slight_smile:

Simulation still not working on desktop or web!

Just worked for me. What is happening when you try? Are you using hardware nodes (button, POT, LCD, etc.)? They will never work in simulation because you cannot connect physical hardware to the simulator. You need to replace these inputs and outputs with tweak and watch nodes.