Tweak string issue

Im on windows 10 every time im try to upload any tweak string i have compilation error so… It seems that i can not use it, even on a example tutorial i cant run it, im a beginer and also im spanish sorry my english i want to notifies an error, i hope somebody should tell me whats wrong on it , by the moment i will check if changing language keyboard preference could affect

We would be able to help you better if we knew how you are using tweak (like a picture of the simplest program that gives the error) and what the actual error is. You will probably have to scroll back to see what the original error was; the visible text will probably only say “an error occurred above”

Just a guess here… As you are spanish, could it be that XOD is not happy with the keyboard settings being non english. And tgherefore not being happy with the ascii codes for the string values you may be trying to transmit?

Whilst this may appear to be rubbish, can i suggest maybe you change your language / local settings on windows via the windows control panel and try again to compile snd see what happens… it will either work or fling the same errors. Once tried means its confimed that it would not be that issue

Begin compiling code for the board Arduino/Genuino Uno 📦

Using board ‘uno’ from platform in folder: C:\Users\elnombrequedesees\xod_packages_\packages\arduino\hardware\avr\1.6.21
Using core ‘arduino’ from platform in folder: C:\Users\elnombrequedesees\xod_packages_\packages\arduino\hardware\avr\1.6.21

Detecting libraries used…

“C:\Users\elnombrequedesees\xod\packages\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Users\elnombrequedesees\xod\packages\packages\arduino\hardware\avr\1.6.21\cores\arduino” “-IC:\Users\elnombrequedesees\xod\packages\packages\arduino\hardware\avr\1.6.21\variants\standard” “C:\Users\ELNOMB~1\AppData\Local\Temp\arduino-sketch-6CDFBA9160418AED4C223FC601756CC9\sketch\xod_1574334233206_sketch.ino.cpp” -o nul

Generating function prototypes…

“C:\Users\elnombrequedesees\xod\packages\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Users\elnombrequedesees\xod\packages\packages\arduino\hardware\avr\1.6.21\cores\arduino” “-IC:\Users\elnombrequedesees\xod\packages\packages\arduino\hardware\avr\1.6.21\variants\standard” “C:\Users\ELNOMB~1\AppData\Local\Temp\arduino-sketch-6CDFBA9160418AED4C223FC601756CC9\sketch\xod_1574334233206_sketch.ino.cpp” -o “C:\Users\ELNOMB~1\AppData\Local\Temp\arduino-sketch-6CDFBA9160418AED4C223FC601756CC9\preproc\ctags_target_for_gcc_minus_e.cpp”

“C:\Users\elnombrequedesees\xod\packages\packages\builtin\tools\ctags\5.8-arduino11/ctags” -u --language-force=c++ -f - --c+±kinds=svpf --fields=KSTtzns --line-directives “C:\Users\ELNOMB~1\AppData\Local\Temp\arduino-sketch-6CDFBA9160418AED4C223FC601756CC9\preproc\ctags_target_for_gcc_minus_e.cpp”

Compiling sketch…

“C:\Users\elnombrequedesees\xod\packages\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Users\elnombrequedesees\xod\packages\packages\arduino\hardware\avr\1.6.21\cores\arduino” “-IC:\Users\elnombrequedesees\xod\packages\packages\arduino\hardware\avr\1.6.21\variants\standard” “C:\Users\ELNOMB~1\AppData\Local\Temp\arduino-sketch-6CDFBA9160418AED4C223FC601756CC9\sketch\xod_1574334233206_sketch.ino.cpp” -o “C:\Users\ELNOMB~1\AppData\Local\Temp\arduino-sketch-6CDFBA9160418AED4C223FC601756CC9\sketch\xod_1574334233206_sketch.ino.cpp.o”

C:\Users\ELNOMB~1\AppData\Local\Temp\xod_temp_sketchbookEFtotM\xod_1574334233206_sketch\xod_1574334233206_sketch.ino: In constructor ‘xod::xod__debug__tweak_string_16::State::State()’:
C:\Users\ELNOMB~1\AppData\Local\Temp\xod_temp_sketchbookEFtotM\xod_1574334233206_sketch\xod_1574334233206_sketch.ino:969:24: error: array used as initializer
State() : view(buff) {}
^

Error: exit status 1
Compilation failed.
Compilation failed
Command C:\Program Files\XOD IDE\resources\arduino-cli.exe --config-file=C:\Users\ELNOMB~1\AppData\Local\Temp\arduino-clisDV1bg\.cli-config.yml compile --fqbn arduino:avr:uno --verbose C:\Users\ELNOMB~1\AppData\Local\Temp\xod_temp_sketchbookEFtotM\xod_1574334233206_sketch failed with code 1
The generated C++ code contains errors. It can be due to a bad node implementation or if your board is not compatible with XOD runtime code. The original compiler error message is above. Fix C++ errors to continue. If you believe it is a bug, report the problem to XOD developers.

im allready try to use US keyboard the issue remains

Hello! Sorry for the late reply. Yes, it is a bug which is already fixed in the development version (https://github.com/xodio/xod/pull/1902). The fix will be included in 0.32.0.

Meanwhile, you can go to tweak-string-16 C++ implementation and fix it by hand. Replace:

char buff[17] = "";

with:

char buff[17];

there.

allright solved
thanks