N0 USB connection after upgrade to on Mac

I upgraded to build and added support for WeMos D1 but when I when to upload I have no USB serial port

I have tried different boards (Uno and the D1) no difference. Also changed USB cables and on a MacBook Pro with USB C if that makes a difference.

Have gone to the Arduino IDE and I get a serial port which points me back here - Help

Update just installed XOD 25.1 on a MBA with 10.13.6

same problem no useful serial ports just:

Upgrading original MBpro now

Ok no luck after update to 25.1 but just tried a UNO and it finds / creates a port:
/dev/tyy.usbmodem14301 which I would expect so seems to be a WeMos D1 issue

any help welcome - I’m a noob so be gentle :slight_smile:

1 Like

Hello and welcome!
Have you tried to install a driver from https://wiki.wemos.cc/products:d1:d1_mini ?

No I hadn’t but I have now but sadly no difference.

I tried twice and followed the instructions in the read.me

If I open terminal and do ls /dev/tty* there is only the ports mentioned prior