Arduino Nano Every

Hello everyone! I’m having trouble uploading to my board. When I select the Nano Every-board I get these options in the Registers emulation box:

Atmega328 or “None (Atmega4809)”

On the board there is a component named Atmel MEGA 4809 so I guess I should use that one but when I do I get error:

Choosing the other option gets the same result.
I bought 3 of the same boards directly from the Arduino website and have tried two of them without any luck.

Does anyone have any ideas?

Hi, @dnl. What is your board? Exactly. Name, spec, etc.

Hey, @gabbapeople. Unsure if it is what you’re looking for but I took it from the tech specs on the Arduino website:

Datasheet links:



Can you copy here the full upload log. With the place where the c++ error is mentioned.

@dnl smth is wrong with the UART node use.

virtual HardwareSerial* toHardwareSerial() {
  • nano “classic”: Serial is “shared” between the USB and RX/TX pins, so Serial1 is not available (or share the same bus?).
  • new nano EVERY: Serial is the USB, Serial1 is RX and TX, both available independently and concurrently.

What is your patch? can you attach a screenshot?

I think by patch you mean this


There is a small bug during upload to Arduino Nano Every board (not Arduino Nano). We will fix it in the next XOD release.

For those who want to flash the Every board right now, there are two ways.

  1. Use the dev XOD build. Pre-adding the condition to the packages/xod-arduino/platform/uart.h file.
class arduino::HardwareSerial;
class HardwareSerial;
class SoftwareSerial;
  1. Flash the patch using the Arduino IDE. Compile the Arduino IDE code by clicking the Show code for Arduino IDE button in XOD. Then, find the line class HardwareSerial; in the code and replace it with class arduino:: HardwareSerial;

We apologize for this inconvenience.

Hi @gabbapeople,

the work on XOD you do is really fine! So you dont have to apologize for a bug like that!

I tried to solve your first solution, but can’t finde the right path. I found uart.h at that place:

I add the condition youre send but that doesn’t work and that only uart.h i could finde at this place.
I would appreciate it if you could guide me

Your second solution work fine, but I use the st7735 library & graphics and Arduino IDE can’t compile it.

The first solution works only for DEV assembly, Linux\MacOS.
For the second solution you can manually add files from XOD IDE\resources\workspace\__ardulib__\Graphics and C:\Program Files\XOD IDE\resources\workspace\__ardulib__\ST7735 to your Arduino IDE project folder.

Thank you so much for your help! May I ask if the next release is scheduled anytime soon?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.