Mpu6050-calibrate not working

Hi, I tried following this tutorial for a self-balancing Mbot and although I can get the values of the watch I connected to the mpu6050-yrp-linear-accel ROLL, I cannot get these watch values when I try the mpu6050-calibrate. I read to try with deter or clock, even deploying the program and switching off the Mbot, then on again. But when I do this I only get the constant value 0.00.

Does anyone know how to fix this? I am using the same Mbot type, as well as the same sensor.
I tried to follow the tutorial without that step, but if I do that the Mbot does not self-balance, so I think it might be a necessary step.

hi! ysanchez
Indeed, this library is old and it should be thoroughly reworked for the last XOD versions.

I promise to fix all the nodes as soon as I have time. But by now I’ve modified the calibration patch to solve your problem.
Checkout the new calibration one, it should work for the Mbot robot.

I remind you the key points:

  • Install your IMU module horizontally.
  • Upload the calibration patch using debug mode.
  • The calibration process can be observed in the XOD console.
  • Do not touch and move the sensor until the calibration process is complete.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.