Getting error while calibrating MPU6050

#1

I am trying to calibrate MPU6050 but this error in page is constantly unable to deploy. I have tired third party required libraries. I don’t what wrong.

gabbapeople library used for it.

Future any guidance on Arduino + MPU6050 + L293D Motor Diver self balancing bot would be highly appreciated.

0 Likes

#2

hi, attach the detail of the error, copy what is on the red and paste it here.

0 Likes

#3

compilation terminated.

Error: exit status 1
Compilation failed.
Compilation failed
Command C:\Program Files\XOD IDE\resources\arduino-cli.exe --config-file=C:\Users\ayub\AppData\Local\Temp\arduino-clirfSG9S\.cli-config.yml compile --fqbn arduino:avr:mega:cpu=atmega2560 --verbose C:\Users\ayub\AppData\Local\Temp\xod_temp_sketchbookZRoUXb\xod_1553498402219_sketch failed with code 1
The generated C++ code contains errors. It can be due to a bad node implementation or if your board is not compatible with XOD runtime code. The original compiler error message is above. Fix C++ errors to continue. If you believe it is a bug, report the problem to XOD developers.

0 Likes

#4

This basically just says “There were errors above”. You need to scroll back to see the actual errors.

2 Likes

#5

@gweimer: now, i am facing new problem. my code for calibration has been uploaded somehow. but not getting any reading wires are connected as they should. please guide me on this.

0 Likes

#6

Std Arduino issue probably…board initializes communication before XOD is ready to receive. Reset board after program is uploaded and XOD is ready & watch nodes should start displaying data.

0 Likes

#7

@gweimer: as you said i have done the same it display values only 0 for all axis.

0 Likes

#8

You need to send a signal to the INIT pin. You can use a clock node to send signals repeatedly, or a boot and defer nodes to send a signal soon after boot.

0 Likes

#9

tried Boot + Defer it worked but it stops not working constitutionally. Tried clock its not working. Don’t know how it work.

0 Likes

#10

By default, clock node will provide a pulse every second. The clock-TICK pin should be connected to the INIT pin of your calibrate node. If calibrate takes longer than 1 second, you should increase the clock-IVAL time.

0 Likes

#11

:shushing_face: not working in my case.

0 Likes