MPU 6050 Failed Communications

Okay, so I am new to XOD and trying to use the gabbapeople/mpu6050 library. I am interfacing a SEN0142/MPU6050 to a standard Arduino Uno. Everything works okay in the Arduino IDE. I have the MPU6050 connected to the UNO via SCL>A5; SDA>A4; INT>2. However, when I run it in XOD I get the following Upload Failure message:

Traceback (most recent call last):
File “C:\Users\deana\xod_packages_\packages\esp8266\hardware\esp8266\2.7.4/tools/upload.py”, line 65, in
esptool.main(cmdline)
File “C:/Users/deana/xod/packages/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\esptool.py”, line 2890, in main
esp.connect(args.before)
File “C:/Users/deana/xod/packages/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\esptool.py”, line 483, in connect
raise FatalError(‘Failed to connect to %s: %s’ % (self.CHIP_NAME, last_error))
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header

Error during Upload: uploading error: uploading error: exit status 1
Upload failed
Command Process exited with code 1
Make sure the board is connected, the cable is working, the board model set correctly, the upload port belongs to the board, the board drivers are installed, the upload options (if any) match your board specs.

I’ve tried everything I can think of to resolve?

If you have an Uno, I don’t think XOD should be trying to connect to ESP8266. Sounds like you are selecting the wrong model when you do the upload. I use board model “Arduino Uno WiFi” when uploading to an Uno board.

1 Like