How should we call watch counterparts?


We have watch nodes to monitor values during debug sessions. Creating their counterparts to adjust/set/tweak values in real-time would be a handy feature. One node could look like an input combined with a slider to set numeric values, another is some kind of toggle switch to provide booleans, yet other is a button-like to trigger pulses.

The question is how should we name them? I can’t find a good metaphor, so ask help from you, dear xoders.

Things came into my head at the moment:

  • knob — is it OK? I doubt the metaphor is intuitive enough
  • adjuster?
  • handle — can be confused with handles from C/C++ which mean a different thing
  • parameter — too vague, not associated with the temporal nature of debug sessions
  • tweak — looks OK, need a native speaker advice
  • tuner — looks OK too
1 Like
Watch-graphic, would show data visually and allow export to csv

In my head they would operate as a programmable Potentiometer, and we “Trim” a pot to a set position.

" Trimming Node “
” Trimmer Node "

1 Like

Merci pour ce merveilleux programme
TouchNode !


How about tweak-number, tweak-boolean, etc.?

adjust-* would be almost as good in my opinion.

interfere-* could have some interesting connotations and contrast to just watching :slight_smile:

Triggering extra pulses in the middle of a program run could have some interesting results…do you end up with multiple pulses flowing simultaneously? I guess you could have the same thing splitting pulses in a patch; the data-flow programming equivalent of forking in a loop…


For different types of buttons you can use:
Bang or Toggle (Puls), Press(boolean) node or you have a node with a choice possibility.
In VVVV they call it (IOBox).
I also like trim as a potentiometer name.
If it’s easier to program, you can also use two press buttons to move up or down number values.