Fault message when transfering programm to Arduino Uno

Hi all,

I just downloaded the XOD programm. Works great is is very intuitive. Only problem is that I can’t upload to my Arduino Uno. I keep getting this code:

(see picture)

Any advice?
I re-installed XOD and Arduino IDE, no result…

Windows 10, 64bit.

Hello and welcome!

:face_with_monocle: I saw this error once. The reason was in a Kaspersky antivirus is running. I don’t understand why it changes the certificate chain, but disabling it for the time of the toolchain download (happens once) solved the issue.

Do you have any aggressive anti-virus software? Can you download the archive from the given URL with your browser?

Hi nkrkv,

Thanks for the quick response.
I do indeed have a Kaspersky antivirus running.

The liberary in the link did got downloaded, but I don’t know what to do with it now. Can I insert the file somwere?


I disabled my Kaspersky, deleted XOD, and downloaded it again.
Now XOD is stuck on:

It does not stuck, it downloads and unzips. It can take up to few minutes. Try to wait a little longer.

Hi nkrkv,

I tried it several times now. 1h, 4h, Whole night… It will not load/install.
Any idea?

I think the archive became damaged after the first interruption. You can try to manually delete it and try again or setup the toolchain manually. See Can I manualy install the toolchain?


Thanks for all the info.
I could not fix the problem, took a second PC, installed it there. It works fine on that one.
I’ll try it again one day soon.