Tool chain certificate


#1

brand spanking new to xod, fairly new to audrinuo, been reading and reading on forum rules, and forum topics. So my problem “tool chain certificate self signed”, read a couple forums on this, downloaded user/%username%/AppData/Roaming/xod-client-electron/packages/arduino/avr/boards.txt the instructions to insert/install this were not very clear, and I am running win7 so the mac example did not resemble what i found when I navigated to the folder. I love the concept of xod, but if I cant even upload to make it to the 3rd step of the tutorials it is dead before even starting. from what i read kasperski could be part of the problem, cant figure out how to make an exception for xod, and cant remember/ find how to pause kasperski. surely some one on here must have experienced these specific issues that can pass on the solution, pls help if you can? am I in over my head? usually that is determined by ones determination, by stubbornness alone I will often stumble upon the answer even if only by chance.


#2

so I figured out how to pause kaspersky, and got this, Upload failed. ChildProcessError: Command failed: “C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\arduino-builder.exe” -hardware=“C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\hardware” -hardware=“C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\packages” -libraries=“C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\workspace_ardulib_” -tools=“C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\tools” -tools=“C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\packages” -fqbn=“arduino:avr:uno” -build-path=“C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp\build” “C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp\xod-arduino-sketch.cpp”
c:\users\pauls hot rod\appdata\roaming\xod-client-electron\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2\bin…/lib/gcc/avr/4.9.2/…/…/…/…/avr/bin/ar.exe: unable to rename ‘C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp\build\core\core.a’; reason: File exists
exit status 1
"C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\arduino-builder.exe" -hardware="C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\hardware" -hardware="C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\packages" -libraries="C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\workspace\__ardulib__" -tools="C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\tools" -tools="C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\packages" -fqbn="arduino:avr:uno" -build-path="C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp\build" "C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp\xod-arduino-sketch.cpp" (exited with error code 1)

Upload failed. ChildProcessError: Command failed: “C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\arduino-builder.exe” -hardware=“C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\hardware” -hardware=“C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\packages” -libraries=“C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\workspace_ardulib_” -tools=“C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\tools” -tools=“C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\packages” -fqbn=“arduino:avr:uno” -build-path=“C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp\build” “C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp\xod-arduino-sketch.cpp”
c:\users\pauls hot rod\appdata\roaming\xod-client-electron\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2\bin…/lib/gcc/avr/4.9.2/…/…/…/…/avr/bin/ar.exe: unable to rename ‘C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp\build\core\core.a’; reason: File exists
exit status 1
"C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\arduino-builder.exe" -hardware="C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\hardware" -hardware="C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\packages" -libraries="C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\workspace\__ardulib__" -tools="C:\Users\pauls hot rod\AppData\Local\Programs\XOD IDE\resources\arduino-builder\tools" -tools="C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\packages" -fqbn="arduino:avr:uno" -build-path="C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp\build" "C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp\xod-arduino-sketch.cpp" (exited with error code 1)


#3

Weird.

All I can suggest for now is to try to remove the C:\Users\pauls hot rod\AppData\Roaming\xod-client-electron\upload-temp directory.


#4

k ill try that thank you, being a temp directory means it cant hurt any thing by deleting it right?


#5

Yes, that’s right. It is re-created automatically when necessary.


#6

If you still have the problem, version 0.25.0 should fix it as we changed the mechanics of toolchains installation.