IDE hangs on “Installing toolchains...”

I just downloaded the desktop, and tried turning on the LED, but when I try to deploy the little green progress bar stops about a quarter of the way through and nothing ever happens??? does anybody know what I’m doing wrong???

I get this message:
· Transpiling…
· Project was successfully transpiled. Searching for device…
· Port with connected Arduino was found. Installing toolchains…

Did you wait lomg enough? It’s not as fast as the Arduino IDE

I waited at least 5 minutes. it shouldn’t take that long right?

Definitely not, wich board are you using and wich board you set on the software for deployment, we need to see as many details as possible to figure out the problem

The first upload has to download and install toolchain. Time needed will depend on your internet connection. Interrupting the download will leave a corrupt toolchain file that causes problems for future uploads. A search for manually installing toolchain should give you several other threads on this topic.


everything looks right as far as the board, I’m using an uno clone, I tried a better internet connection and it still just stays on the “installing toolchains” thing and nothing ever happens. this is really frustrating

A picture of your board and a screenshot of the deployment menu will help a lot, please send it if you can

okay so now it works, but only if I select “compile in the cloud”. for some reason i cant compile on my own. has this happened to anyone else? if so please tell me how to fix

Yeah, we have that awful bug with download corruption on interrupt.

To recover delete C:\Users\Pierre\AppData\Roaming\xod-client-electron\packages and try again. Give enough time to download ~200 MB archives. They contain AVR GCC compiler and avrdude uploader.

I’m having the same problem. I’m running a MacBook Pro, any help for me?

The issue was resolved in 0.21.0.
Update your XOD IDE and just try uploading again. It will automatically detect corrupted toolchains and redownload them.