Error with digital-write

This simple patch gives me an error.


In order to compile I have to comment this line in digital-write node

//#pragma XOD evaluate_on_pin disable


Begin compiling code for the board Arduino Uno 📦

C:\Users\Cesar\AppData\Local\Temp\xod_temp_sketchbook98XhiA\xod_1601190379205_sketch\xod_1601190379205_sketch.ino: In function 'void xod::detail::handleDebugProtocolMessages()':
C:\Users\Cesar\AppData\Local\Temp\xod_temp_sketchbook98XhiA\xod_1601190379205_sketch\xod_1601190379205_sketch.ino:1331:35: error: 'struct xod::TransactionState' has no member named 'node_0_isOutputDirty_OUT'; did you mean 'node_2_isOutputDirty_TICK'?
                     g_transaction.node_0_isOutputDirty_OUT = true;

C:\Users\Cesar\AppData\Local\Temp\xod_temp_sketchbook98XhiA\xod_1601190379205_sketch\xod_1601190379205_sketch.ino: In function 'void xod::runTransaction()':
C:\Users\Cesar\AppData\Local\Temp\xod_temp_sketchbook98XhiA\xod_1601190379205_sketch\xod_1601190379205_sketch.ino:1391:55: error: 'struct xod::TransactionState' has no member named 'node_0_isOutputDirty_OUT'; did you mean 'node_2_isOutputDirty_TICK'?
             ctxObj._isOutputDirty_OUT = g_transaction.node_0_isOutputDirty_OUT;

Error during build: exit status 1
Compilation failed
Command Process exited with code 1
The generated C++ code contains errors. It can be due to a bad node implementation or if your board is not compatible with XOD runtime code. The original compiler error message is above. Fix C++ errors to continue. If you believe it is a bug, report the problem to XOD developers.

Hello. I had exactly the same error. And I also fixed it by deleting or commenting out this line. This bug is related to tweak. It works with other nodes, but doesn’t work with tweak.
By the way, I still don’t understand what function they perform
#pragma XOD evaluate_on_pin disable
#pragma XOD evaluate_on_pin enable input_UPD
#pragma XOD error_raise enable

Very strange, I was able to fix the error without changing the patch.

As you can see, I just drew another line from the tweak to another patch

1 Like

Thanks for commenting, I noticed something similar before when writing a library, if I added the line and had digita-write nodes, the error would appear.

Now this seems to be a bug.

I also see that the c ++ implementation of your node does not seem to be updated to 0.35.x

No, I have the most recent version. I honestly don’t know why the patch hasn’t been updated. And by the way, even if there is a new version, you can still write in the old way.

There is a fork of the xod folder inside libraries, delete it and start xod again.
If you’ve ever moved a node or changed something, a copy of the folder is created.

This change occurs when you save any patch.

Thanks for the report.
Just released a new version 0.35.3 with the fix of this problem.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.