Button error - undeclared identifier

When inserting a simple button in XOD i get this error, but i dont know how to fix it, because i believe its not something i did wrong.

Edit - With a Arduino Nano (old bootloader model)

Edit 2 - when downgrading to XOD version 0.20.1 it works - i have not tried any versions in between 0.20 and 0.31

Edit 3 - same problem with the online ide, just inserting a button is enough for it to fail

1 Like

What is the library you are using? XOD changed a lot since version 0.20.1

Hello and welcome!

Starting from 0.31.0 the standard xod/common-hardware/button uses built-in pull up resistor. And for the simulation mode, the INPUT_PULLUP is not defined. That’s a bug. Will fix it in several hours… I hope so.

Fixed. Just try again on the latest version of the XOD IDE.

Well now i just get a new error, even with no blocks added.
Didn’t download but just tried it online.

Thanks for the fast response BTW and an awesome tool you guys build here.

Looks like your web browser does not have a TextEncoder object, that are used in simulation.
Can you tell which browser do you use and what is the version?

In any case, it will work in the desktop version :slight_smile:

Cool i will try

Microsoft Edge 44.18362.329.0

Yep, Microsoft Edge does not support it, so we need to fix it.

But we have some other issues with IDE on Microsoft Edge, including very slow rendering.
So I’m not sure that we’ll fix it soon and recommend to use one of these browsers: Chrome / Chromium / Firefox or download the desktop version :slight_smile:

I downloaded the 0.31 version and the bug is fixed, but a new one popped up :slight_smile: