Xod/common‑hardware/dht2x‑thermometer

Does any one know why I cant add this to my library
xod/​common‑hardware/​dht2x‑thermometer

I am new to XOD and was very excited when I saw the first video where it was used. I have been working on a humidity and temperature (DHT11) project to turn on an extraction fan in the bath room when a certain humidity is reached & then turn it off when a lower value (about 5% hysteresis) is reached. Having difficulty in Arduino IDE getting my head around the program flow etc.

So I have downloaded XOD worked through several of the tutorials , decided to give the humidity project a try but could not find a DHT node in the installed libraries , found the xod/​common‑hardware/​dht2x‑thermometer node but it wont add?

Thanks
MArtin

xod/common-hardware would be one of the built-in libraries. If you double-click on the workspace (or single-click on the workspace and hit the i key) a search box opens to search nodes. Typing dht should show this node. Click on the node in the search list to add it to your workspace. To add other libraries that others have created, go to File > Add Library and type the library you want to add (like gweimer/utils) and click on the matching library. After that, nodes in that library will be included when you do a node search (or you can browse the nodes in the library in the list of nodes to the left of the workspace).

G’day gweimer,
Thank you for the reply. I have tried what you suggested but only get the xod-dev-dhtt node. When I try to run this in the simulation it returns a long error message.
I have also removed every xod file/folder/library/application from my PC, reloaded it but still no joy. The DHT node that I have seen on youtube videos, in the xode/common-hardware tab is not present.
I have not had time yet to connect to an arduino to see if it will upload and run on that.
Cheers
Martin

You cannot use any physical devices like buttons, LEDs, motors, or sensors in the simulator. There is no way for the simulator to know what values to return for these (or what to do with values sent to them).

Looks like the dht node you found documentation for no longer exists. There are two thermometer nodes under xod/common-hardware, but I doubt either would work with your device; neither has a humidity output. There is a separate xod-dev/dht folder that might have more useful nodes for you. dht2x-hygrometer is probably what you want.

G’day gweimer,
Thank you for your time. Oh I see now, the YouTube video using the DHT never ran it in simulation and that also explains why the other modules (temp) throw up the same error in simulation. So I’m not going completely mad, just a bit naïve.
I will plug my uno in to the pc & see where that gets me.

Many thanks again for your time.

Martin