Uploading Failure

Respected XOD team Members,
I try to upload a simple sketch to Arduino Nano, But it gives an error message. Please can you guide me to solve this issue.

Dear XOD team brothers,
Is there any solution to solve the above issue?

The error is pretty self-explanatory; it can’t find the Arduino to program it. Is it plugged in correctly? Have you selected the correct port to download to? Have you selected the correct Arduino model to download to? Have you tried using a different USB port on your computer to plug the Arduino into?

First of all thanks for the reply & I like to share one more step I executed. Above issue still exist, fortunately I have a another laptop & I was install this XOD 36.1 software freshly & carry out the same above exercise & it was uploading perfectly, So I tried for both two Arduino boards (Nano & Mega) both uploading perfectly. So the end I was decided, the issue on my XOD program was installed on PC was cruppered for some reason. So I uninstalled this XOD 36.1 exe & reinstalled for couple of times & carry out my same experiment, But in the end , I did not succeed.
Dear Brothers Please can you advice me how to remove the XOD files completely from my PC. Why I am saying this, Because every time when I install this exe, I can see some of newly added library files also in XOD exe. So it means , when I adding a library or some bug added to my PC, this may be the reason when I open the XOD exe. on my PC the existing libraries are still their. Even I remove & reinstall freshly , Still I can see the existing library files.
Dear team members, Please can guide me, how to remove my existing added XOD files from my PC.
Awaiting for yours kind reply.

Have you tried uninstalling XOD from the program install/uninstall control panel? This should remove the executables from AppData, but not your workspace.

XOD puts your workspace in C:\Users\USERNAME\xod by default (where USERNAME is your login id). If you install for a single user, XOD will default to C:\Users\USERNAME\AppData\Local\xod-client-electron-updater, C:\Users\USERNAME\AppData\Roaming\xod-client-electron-updater, and C:\Users\USERNAME\AppData\Roaming\XOD IDE. If there is anything you’ve coded that you want to save, you can copy it out of C:\Users\USERNAME\xod to a temporary location, then delete all these folders (check to verify correct paths, then run uninstall, then delete any folders that still exist). I’m guessing XOD is installed under Program Files if you install for all users on the system, but I haven’t tried that option.

Dear Mr.Gweimer, Thanks a lot for your kind assistance and you encourage me to do the above steps. So I do my first to remove the below file ( C:\Users\USERNAME\AppData\Local\xod-client-electron-update), which mean I remove the xod-client-electron-update file from above location & I to use my same XOD exe. 0.36.1 software & try to upload the same existing simple programs to Arduino Nano & Maga, both are uploaded.
Once again many thanks for your guidance & for encouraging me to do such a step.