Support ATmega128 (MegaCore)


#1

hi @nkrkv, is ATmega128 supported?

https://mcudude.github.io/MegaCore/package_MCUdude_MegaCore_index.json

Create a board.txt with url and add package, but then after requesting installation the following message appears

Installing Arduino dependencies... Error: package MegaCore not found 
Could not determine platform dependencies

`C:\Users\Cesar\AppData\Local\Programs\XOD IDE\resources\arduino-cli.exe 
--config-file=C:\Users\Cesar\AppData\Local\Temp\arduino-clikizXY7\.cli-config.yml 
core install MegaCore:avr` failed with code 4

#2

Download and install the package manually, and after a few reboots when I thought it was not possible, there was :man_shrugging:

Now to try

atmega128%20(2)


#3

Wow! I did not know such boards exist… To be honest, I did not know about ATmega128 at all.

The URL you’ve mentioned should be put in C:\Users\You\xod\__packages__\extra.txt. Have you done it?

I’m not sure about the current status of your issue. I see you found the board in the Upload Dialog list. But have you succeeded with the upload itself?


#4

ATmega128 was the Wiring, predecessor of Arduino.
In reality I do not have the board, I have the chips alone and I wanted to use them.

I did not manage to download automatically, I had to create the folders manually and look for the link in the .json to download the latest version.

C:\Users\Cesar\AppData\Local\Programs\XOD IDE\resources\workspace_packages_ I could not
C:\Users\Cesar\Documents_packages_\packages\MegaCore install here

I have not tested yet, just that I have been duplicated and I could not eliminate, I will try to install XOD later


#5

Sorry for the late reply and thanks for the details. Something is messed up :confused:

I cannot understanand the following statement:

Would you elaborate? What you did installed by hand and what’s was done automatically?

You should not touch C:\Users\Cesar\AppData\Local\Programs\XOD IDE\... since 0.25.0 because all packages now go directly to the current workspace which is usually C:\Users\Cesar\xod (but for some reason you have it pointing to C:\Users\Cesar\Documents).


#6

something was wrong, i solved cleaning the installation and reinstalling.
But I could not compile the file, it says not compatible :thinking:


#7

Hello, @cesars!
Thanks for the report.

Could you describe a full step-by-step instruction how to reproduce the bug you get caught?

Also, please try to install this package “automatically” with XOD IDE.
To avoid problems with broken workspace, try this on a new workspace or rename the __packages__ folder in your current workspace (or just delete it, but then you’ll have to reinstall packages).

Here are steps how to install additional packages within XOD IDE:

  1. Open YOUR_WORKSPACE/__packages__/extra.txt file and put the link to the package_*_index.json file on the new line (one URL per line)
  2. Open XOD IDE
  3. Open Deploy dialog (Deploy -> Upload to Arduino…)
  4. Click “Update” button, next to the board select
    Then you’ll see new boards in the board list with a comment “(Not installed)”.
  5. Choose one that you are interested in (“ATmega 128 (Not installed)”).
  6. Click “Upload”
    You’ll see a snack bar message that package is missing with “Download & Install” button.
  7. Click the “Download & Install” button and wait. You can watch the process in the “Deployment” pane in “Installer” tab.
  8. After you see a message that package installed successfully, try to upload it as usual.

If something went wrong, please copy-paste errors that you get.
Check out for errors here:

  • Snack bar error message
  • Errors in Deployment pane on “Compiler” or “Uploader” tabs
  • Unhandled errors in the developers Inspector, “Console” tab (press “Ctrl+Shift+I” on Windows or “Cmd+Option+I” on MacOS)

#8

By the way, I recommend to update XOD IDE to the latest 0.25.2 version before doing all this stuff :wink:


#9

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.