"Blue Pill" board supported?

Congratulations to the update and the new features!

I tried to install support for the “Blue Pill”-Board (STM32F103C) by adding http://dan.drown.org/stm32duino/package_STM32duino_index.json to the packages folder.

The board (Generic STM32F103C series) is shown in the device list.
After clicking on “download & install” the following error message appears:

Installing Arduino dependencies… Error: package stm32duino not found Could not determine platform dependencies

C:\Program Files\XOD IDE\resources\arduino-cli.exe --config-file=C:\Users\OPTIPL~1\AppData\Local\Temp\arduino-cliqTbLxj\.cli-config.yml core install stm32duino:STM32F1 failed with code 4

How can I fix this?


I see, it is counter-intuitive… You should add the URL to the $WORKSPACE/__packages__/extra.txt instead (or along with) putting the actual package_STM32duino_index.json file there.

That is, you should have your extra.txt literally with a single line in it:


Then restart XOD IDE.

After a restart and updating the device list it worked perfectly! :yum:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.