Package Index Broken

Does any one have a suggestion on how to fix this. I have the newest version .30.1


Menu > Deploy > Upgrade Arduino …

what is the board?

I have a Mega2560. I tried the upload tool but it does not have any boards in the dropdown list

Close XOD, delete the folder ...\xod\__ package__ and try again

I deleted the folder and received the same error message. Any other suggestions.

Also thanks for the help.

The selected model is not visible in the image. You must wait for the list to load. Press “update”

That error message comes up as soon as I click on “Upload to Arduino” I think that it is keeping it from loading the list of the boards.

Also i tried to used the update button and get a similar error message

rename xod folfer to xod -old, uninstall and reinstaller.
After installing, deploy> update in menu, when compiling wait for the list to load, sometimes it takes a while, then compile … there can leave a message in blue with a download button, click there … When finished, compile again.

So i uninstalling XOD and deleting the xod folder. reinstalled the program-opend XOD. plugged in my mega2560 and when to “Deploy” - “Upload project” as soon as i clicked on “upload” given i was given the error message “package index broken”. I left it on that screen for about 20 min it never loaded the list of boards. I also tried “deploy” - “Upgrade ardiuno”. it said checking for updatesbut never did anything else.

It could be a connection failure or the firewall or antivirus that does not allow connection to the server.

Same problem. Tried everything i can think of, opened firewall, installed, reinstalled. Any more ideas???

agh, i give up. Going back to C++

const int XOD_IDE (PieceOfshit)

You can always try it again!