Problem with upload to Arduino

First : add to C: \ Users \ user \ xod \ __ packages__ extra.txt line

Second : accept the installation request and recompile


Works fine now.


If you are using the latest XOD IDE extra.txt should already contain a link to esp8266 package index, so you need only to install package in the IDE without specifying any urls.

Also, by default, extra.txt contains an url to our fixed esp8266 package index, because the latest release of esp8266 (2.4.2) now contains a bug in the platform.txt (and they already fixed it, but did not released yet).

So we recommend to use our URL ( ), instead of official package or you can get an error in uploading stage.

If you already installed official package and get a bug, just replace the URL with ours one and then click “Deploy -> Upgrade Arduino Packages & Toolchains…”. You’ll see an available update to a new version (2.4.3).
Just click the button and wait.

1 Like

Hi there. I’m havning an issue with uploading to Arduino.

Yep, we also experienced this. On a first glance this looks like a temporary issue with, but we are investigating this further.

I’m experiencing this issue as well (Cannot update indexes). Looking forward to getting it figured out!

An emergency update of arduino-cli dependency is required. We are going to release a new hofix version (0.25.3) tomorrow.

1 Like

@talos-99, @stardust-supernova
0.25.3 is released. Please update

Updated version to 0.25.3, still does not work.

Upgrade Packages and Toolchains



What is your XOD version? because in the current one it is Arduino/Genuino Mega o Mega 2560

I uninstalled XOD and installed version 0.25.3 and when I went to download and install the Arduino dependencies I got another error - a code 5

Have you tried again? the first time it gives an error even if it is installing

  1. Choose arduino module
  2. push Update button
    if no(…take place errors…)

3. <Deploy -> Upload to arduino…>
4. Choose arduino module, confirm port
5. Click Update button
6. Ok!

‘cesars’ good! You are right!!!

Ok nearly there left computer alone for twenty minutes installed most boards etc.

Tried to upload tutorial ie blinking led to Arduino nano, right port and board selected tried unplugging board and re connecting but keep getting up load failed AVRdude stk500 not responding.
Any ideas ?

Copy the log here to see the error, otherwise it is difficult to help

Ok set the processor to use old boot loader and every thing is working now, just impatience on my part I think. Tried again without using old boot loader got error massages again, guess I got an old bootloader nano.

Thanks for help.

Great :slightly_smiling_face:

This thread became a heap of somewhat unrelated problems. Let’s keep it for the reference, but close for new messages.

For future readers: feel free to start a new topic with a comprehensive description of an upload problem.