Parse Tabular Node Not Deploying

#1

Hi all! I’ve been trying to get the gabbapeople led example to work and everything is fine until the parse tabular node is introduced. It will not deploy. Im using UNO as my Arduino platform. Is anyone else having a problem deploying this node in this example or on its own? Is there a similar node that will do the same job? Otherwise XOD is truly amazing and has worked perfectly for all of my experiments. Thanks! :slight_smile:

0 Likes

#2

Since the gabbapeople led example and parse tabular are not built-in, it would be helpful to provide links to where you are getting them if you want help.

It would also be helpful to know why it will not deploy. There should be error messages if you scroll back in the pane that shows the failure.

1 Like

#3

Hi thanks for the reply! I found the example in the XOD guide and downloaded the gabbapeople library directly through the XOD ide. I’ve followed the directions exactly and can even get the sketch to work with one pot when I take out the parse tabular nodes. When I try to deploy the example with the parse tabular nodes I get this error. Even trying to deploy them outside of this example gets the same error. Attached is the error:

0 Likes

#4

Here is a link to the example: https://xod.io/docs/guide/uart-led-control/

0 Likes

#5

You’ll need to scroll back to get the original error message. The image you show just says “the original compiler error message is above”, which doesn’t help narrow down the problem.

1 Like

#6

From the beginning of compile sketch:

0 Likes

#7

0 Likes

#8

0 Likes

#9

This is the sketch:

0 Likes

#10

Looks like parse-tabular is broken, it is trying to set output_PTR, but there is no PTR output pin. Either the output pin should be labeled, or the code should be changed to use the default name (?output_OUT?).

2 Likes

#11

Thank you very much for all of your time and help! :smile: I will check that out. I would love to get that node going!

0 Likes

#12

Worked like a charm!!! Thank you @gweimer the node is working once again and I was able to complete the example.

0 Likes