Multiple libraries were found for "SD.h"

Hi everyone! Please tell me what could be the problem!
I tried deleting each of these libraries, it didn’t work.

Begin compiling code for the board DOIT ESP32 DEVKIT V1 :package:

/var/folders/b_/wz9nyffd4b78v0q52sp8j9vc0000gn/T/xod_temp_sketchbookT9wMrq/xod_1676622540266_sketch/xod_1676622540266_sketch.ino: In member function ‘void xod::xod__common_hardware__sd_log::Node<constant_input_CS>::evaluate(xod::xod__common_hardware__sd_log::Node<constant_input_CS>::Context)’:
/var/folders/b_/wz9nyffd4b78v0q52sp8j9vc0000gn/T/xod_temp_sketchbookT9wMrq/xod_1676622540266_sketch/xod_1676622540266_sketch.ino:4782:39: error: ‘O_WRITE’ was not declared in this scope
File file =, O_WRITE | O_CREAT | O_APPEND);
/var/folders/b_/wz9nyffd4b78v0q52sp8j9vc0000gn/T/xod_temp_sketchbookT9wMrq/xod_1676622540266_sketch/xod_1676622540266_sketch.ino:4782:49: error: ‘O_CREAT’ was not declared in this scope
File file =, O_WRITE | O_CREAT | O_APPEND);
/var/folders/b_/wz9nyffd4b78v0q52sp8j9vc0000gn/T/xod_temp_sketchbookT9wMrq/xod_1676622540266_sketch/xod_1676622540266_sketch.ino:4782:59: error: ‘O_APPEND’ was not declared in this scope
File file =, O_WRITE | O_CREAT | O_APPEND);

Multiple libraries were found for “SD.h”

Used: /Users/pein/xod/packages/packages/esp32/hardware/esp32/1.0.6/libraries/SD
Not used: /var/folders/b_/wz9nyffd4b78v0q52sp8j9vc0000gn/T/xod_temp_sketchbookT9wMrq/libraries/SD

Error during build: exit status 1
Compilation failed
Command Process exited with code 1
The generated C++ code contains errors. It can be due to a bad node implementation or if your board is not compatible with XOD runtime code. The original compiler error message is above. Fix C++ errors to continue. If you believe it is a bug, report the problem to XOD developers.

Per Multiple libraries were found for "SD.h" - adafruit industries
[This] isn’t really a problem - it’s informing you that it used the SD library in your sketchbook folder instead of the standard SD library inside the app. You can ignore that message - it’s not an error, it’s just informational.

The reason compile is failing is because the macros used for are not defined, which generally implies that a required header file has not been included. These are standard file I/O parameters, so it seems odd they are not declared…

Sorry, This might help you get going in the right direction, but it doesn’t really help you fix your problem…

Can you suggest possible solutions? I’m sorry I didn’t understand. I thought it was a library conflict.
same error when i compile only one sd-log without other nodes

I don’t know. What seems most likely to me is that sd-log node you are using from xod-common-hardware isn’t working (seems unlikely…), or isn’t working with your Arduino model, or your AVR install for this Arduino model is incomplete/corrupt. There are old threads about manually installing/updating avrtools that you might want to try.

Unfortunately, I don’t know enough about XOD internals to be of much help beyond this, and the developers are from Russia and have been hit by sanctions over Ukraine and we have not heard from them in a while.

You were right the problem was in the controller after its replacement, the error is no more! thanks for your reply!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.