Existing libraries/nodes not able to find 'X.h'

Hi There,

I’m having some new issues with libraries that have worked fine in the past.

  • “xod/uart/soft-uart” is returning “SoftwareSerial.h” file not found.
  • “bradzilla84/kalman-filter/kalman-filter” is returning “Kalman.h” file not found.
  • *I’m also not able to simulate the kalman-filter example in the “bradzilla84/kalman-filter” library. It’s 1 warning a 2 errors as per the bellow;

/ws/sketchbook/bed92c302117ccc5580934d7a430c299ffbef8079afd6557690c30e76df8179d/sketch/sketch.ino:1888:23: error: no matching function for call to ‘rand_r’
int rnd = rand_r(seedp);
/ws/arduino_data/packages/xod/tools/emscripten/1.39.2/emscripten/system/include/libc/stdlib.h:106:5: note: candidate function not viable: no known conversion from ‘unsigned long *’ to ‘unsigned int *’ for 1st argument
int rand_r (unsigned *);
/ws/sketchbook/bed92c302117ccc5580934d7a430c299ffbef8079afd6557690c30e76df8179d/sketch/sketch.ino:1885:66: warning: implicit conversion from ‘unsigned long’ to ‘float’ changes value from 4294967295 to 4294967296 [-Wimplicit-int-float-conversion]
seedp = (unsigned long)(getValue<input_SEED>(ctx) * ULONG_MAX);
~ ^~~~~~~~~
/ws/arduino_data/packages/xod/tools/emscripten/1.39.2/emscripten/system/include/libc/limits.h:33:32: note: expanded from macro ‘ULONG_MAX’
#define ULONG_MAX (2UL
/ws/sketchbook/bed92c302117ccc5580934d7a430c299ffbef8079afd6557690c30e76df8179d/sketch/sketch.ino:1993:10: fatal error: ‘Kalman.h’ file not found
#include <Kalman.h>

I’ve tried reloading the libraries and working in a new project.

Is this something I’m doing wrong?

Thanks for any help!

Serial & other functions are NOT going to work in simulator; there is no way to connect hardware to the simulator, so there is no reason for those libraries to work.

Do you also have the problem downloading code to an Arduino board?


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.