Modeling error how to solve the problem

#1


prompt in what a problem ???
Generating C++ code for simulation…
Building…
=== Skipped 0 lines ===
Non-zero exit code of compiler
XODMAIN.cpp:1190:33: error: use of undeclared identifier ‘LOW’
if (pulseInLength(port, LOW, 70) == 0)
^
XODMAIN.cpp:1196:43: error: use of undeclared identifier ‘HIGH’
pulseLength = pulseInLength(port, HIGH, 80);
^
XODMAIN.cpp:1211:24: error: use of undeclared identifier ‘HIGH’
digitalWrite(port, HIGH);
^
XODMAIN.cpp:1216:5: error: use of undeclared identifier ‘delayMicroseconds’
delayMicroseconds(30);
^
XODMAIN.cpp:1220:19: error: use of undeclared identifier ‘INPUT_PULLUP’
pinMode(port, INPUT_PULLUP);
^
XODMAIN.cpp:1222:29: error: use of undeclared identifier ‘LOW’
if (pulseInLength(port, LOW, 90) == 0)
^
XODMAIN.cpp:1229:29: error: use of undeclared identifier ‘HIGH’
if (pulseInLength(port, HIGH, 90) == 0)
^
XODMAIN.cpp:1240:24: error: use of undeclared identifier ‘HIGH’
digitalWrite(port, HIGH);
^
XODMAIN.cpp:1253:24: error: use of undeclared identifier ‘HIGH’
digitalWrite(port, HIGH);
^
XODMAIN.cpp:1278:28: error: use of undeclared identifier ‘LOW’
digitalWrite(port, LOW);
^
XODMAIN.cpp:1470:10: fatal error: ‘Wire.h’ file not found
#include <Wire.h>
^~~~~~~~
11 errors generated.
shared:ERROR: compiler frontend failed to generate LLVM bitcode, halting

The generated C++ code contains errors. It can be due to a bad node implementation
or if your board is not compatible with XOD runtime code. The original compiler error
message is above. Fix C++ errors to continue. If you believe it is a bug, report the
problem to XOD developers.

0 Likes

#2

Hi, DHT11 and other nodes include arduino library, can not be simulated, use upload and debug

0 Likes

#3

with this more or less clear ,there is a more significant problem when loading and checking the program code in the arduino ide the problem appears

0 Likes

#4

In arduino IDE does not have the library installed LiquidCrystal_i2c

image

0 Likes

#5

unfortunately, I do not use the desktop version of xod (my operating system does not support it)how can I transfer the library that uses xod in this code??

0 Likes

#6

ah ok …
Although I can not start it, maybe I can extract the library from here, but in the IDE
C:\Users\User\AppData\Local\Programs\XOD IDE\resources\workspace\__ardulib__\LiquidCrystal_I2C

In IDE Arduino > sketch > Include Library > Manage Library > search LiquidCrystal_i2c …install “by Frank de Brabander”

0 Likes

#7

if I understand correctly then xod (in code creation uses a similar library)

0 Likes

#8

Some nodes or libraries XOD use arduino libraries, you can use an i2c device, and create your library with xod/i2c nodes, this will use the wire library.
Wire is a standard library, you will not need to download it for IDE.

0 Likes

#9

the problem remained, did everything according your instructions

Blockquote at first I thought that my 3 like libraries and possible conflict of interest, removed everything leaving only the one (which is from “franc de Brabandere”) the result is the same error

0 Likes

#10

0 Likes

#11

here is the full error message can help to understand:

C:\Users\C39C~1\AppData\local\temp\arduino_modified_sketch_477100\sketch_apr07a folder.Eno: in the ‘void’ function xod::xod__common_hardware__text_lcd_16x2_i2c::evaluate(xod::xod__common_hardware__text_lcd_16x2_i2c::Context)’:

sketch_apr07a:1595: error: no matching function for call to ’ LiquidCrystal_I2C:: begin ()’

     LCD>start();



                ^

C:\Users\C39C~1\AppData\Local\Temp\arduino_modified_sketch_477100\sketch_apr07a.ino: 1595: 20: note: candidate:

In the file included from C:\Users\C39C~1\AppData\Local\Temp\arduino_modified_sketch_477100\sketch_apr07a.ino: 1471:0:

C:\Users\кирилл\Documents\Arduino\libraries\LiquidCrystal_I2C/LiquidCrystal_I2C.h:58:8: note: void LiquidCrystal_I2C:: begin(uint8_t, uint8_t, uint8_t)

void begin(uint8_t cols, uint8_t rows, uint8_t charsize = LCD_5x8DOTS );

    ^

C:\Users\кирилл\Documents\Arduino\libraries\LiquidCrystal_I2C/LiquidCrystal_I2C.h:58:8: note: candidate expects 3 arguments, 0 provided

Using library wire in folder: C:\Users\кирилл\Documents\Arduino\libraries\Wire (heritage)

Use the library LiquidCrystal_I2C version 1.1.1 from the folder: C:\Users\кирилл\Documents\Arduino\libraries\LiquidCrystal_I2C

output status 1

no matching function for call to ’ LiquidCrystal_I2C:: begin ()’

Yes , sorry for my English I use a translator

0 Likes

#12

replace the library LiquidCrystal_i2c for this

http://image.dfrobot.com/image/data/TOY0046/LiquidCrystal_I2Cv1-1.rar

I have compiled without errors in the IDE

0 Likes

#13

again failure . I don’t think there’s a problem with the library.
most likely a compilation error in xod(xod gives errors in the code )

0 Likes

#14

1 the arduino ide compiler references the string “begin”
2 no matching function for call to

0 Likes

#15

Use https://github.com/xodio/xod/tree/master/workspace/__ardulib__

I did not realize before these

0 Likes

#16

the link you gave me is a library (LiquidCrystal_I2C) specifically for working with xod code, am I right ???

0 Likes

#17

the problem was solved ! only after I installed the library that Cesars provided me with a link , is it specifically written to work with xod

0 Likes

closed #18

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

0 Likes