Installing Arduino avr@1.8.2

I am a new user and get message to download and install dependancies (AVR boards) when trying to deploy code for the first time.
This is the error message I get:-

Installing Arduino dependencies…
Tool arduino:avr-gcc@7.3.0-atmel3.6.1-arduino5 already installed
Tool arduino:avrdude@6.3.0-arduino17 already installed
Tool arduino:arduinoOTA@1.3.0 already installed
Downloading arduino:avr@1.8.2…
arduino:avr@1.8.2 downloaded
Installing arduino:avr@1.8.2…
Error: moving extracted archive to destination dir: rename C:\Users\utente\xod_packages_\tmp\package-597129111\avr C:\Users\utente\xod_packages_\packages\arduino\hardware\avr\1.8.2: A
Cannot install platform
Error Access denied
Process exited with code 1
System windows 10 professional
i have installed Arduino 1.8.12

Permissions on your system are not letting the software rename the folder after it is extracted. If the destination folder avr\1.8.2 already exists, it might be enough just to delete it.

1 Like

Thank you for the answer
I solved the problem copying the folder AVR from Arduino 1.8.12 in the folder XOD…avr\1.8.2
Best Regards

I am having the exact same issue, at the file location
there are not any files at all just a few more directories with a pdf product brief.
Tried re-naming the directory but that doesn’t work either.
is there a place I can manually down-load the files and place them in the correct directory?

I’ve been working on this, I wanted to add an update. previously I was using my laptop, decided to install on my desktop and found it all worked fine, well it uploaded certain bugs in the program uploaded but the point is it installed all the things it needed and uploaded to the arduino.

I digress, I located the avr directory on the desktop, copied that to the correct location on the laptop and we have a situation where it will now upload to the Arduino.

Point is that the required files which would have been expected to be in the tmp directory on the laptop were not, indeed on my desktop that directory is empty suggesting that there is an step in the normal installation which deletes these tmp files.

Strange situation, both machines running windows 10 pro.

I would not expect to find any files in the tmp directory if it worked. Tmp is short for temporary. If everything worked, the files would get moved to their final location and no longer be in tmp.

I think I had a similar problem, I recommend uninstalling XOD.

Go to the Users/you_user/xod/ folder, and just leave the __ lib __ folder.

Reinstaller XOD, after starting XOD, going to Deploy Upgrade arduino packages & Toolchains will request the downloads.

Re-install would have been the next step, quite happy that it worked by copying the files over from the desktop. thanks for the advice

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.