Cannot install AVR boards


#1

I am a new user and get message to download and install dependancies (AVR boards) when trying to deploy code for the first time.
This is the error message I get:-

Downloading arduino:avr@1.6.23… arduino:avr@1.6.23 downloaded Installing arduino:avr-gcc@5.4.0-atmel3.6.1-arduino2… Error: moving extracted archive to destination dir: rename C:\Users\user\xod_packages_\tmp\package-894986051\avr C:\Users\user\xod_packages_\packages\arduino\tools\avr-gcc\5.4.0-atmel3.6.1-arduino2: Access is denied. Cannot install tool: arduino:avr-gcc@5.4.0-atmel3.6.1-arduino2

Error C:\Users\user\AppData\Local\Programs\XOD IDE\resources\arduino-cli.exe --config-file=C:\Users\user\AppData\Local\Temp\arduino-cliZMC0kb\.cli-config.yml core install arduino:avr failed with code 1 The error has no formatter, which is a bug. Report the issue to XOD developers.

Please help
mijoho


#2

Hello and welcome!

Do you indeed use "user" as your name under Windows? From what I see, there’s some permission problems during the toolchain installation and I have no idea why because C:\Users\user is your dir and you should be allowed to do whatever you like there.

Have you tried to delete C:\Users\user\xod and try again?


#3

Thanks for the reply. I have tried your suggestion but same error. I have created another account on my machine and have managed to lock myself out as win 10 does not appear to recognise passwords. Will reset and try again tomorrow.