DHT-11 and DHT-22 not working at all!

#21

My first time at XOD, so correct me if I’m wrong: You cannot make the DHT11 work? Even if you code BY HAND ?

Or are you just trying to make it work by XOD generated code only?

#22

Hello Jagganath,
Thank you for your reply. However I did find the problem. It is a BUG in the XOD IDE that does not address the DHT properly. Now, through GibHub it does show there is a new way to make it work.
Using different ways to layouting the program. Thanks.
Dave

#23

Hello Jagganath,
I do not understand that you said. “Even if you code BY HAND ?”

Using the XOD IDE programming method is nothing like using the ARDUINO IDE. Two difference animals. Coding in XOD is way different than the text method of the Arduino way. Coding by hand does not apply in this way.
All programming languages are different. Programming by hand is just a way of saying "You typed or used the language, Basic, Fortran, Cobal, C ++ or XOD, the way they must be set down on your desktop editor. This is the XOD way of creating a program, any way you call it is the same end results. You cannot compare the different programming because they are so different from each other.
I do not fully understand your post. If I am wrong please let me know.

#24

Yeah I fully understand now. We used to be a company that sells “middleware” generators. But we produced text, in another language, Like Structure/Function blocks to say COBOL or C or FORTRAN, with inhouse libraries used.

I guess XOD just uploads to Arduino, from designed code blocks to Arduino binaries.

— Life is transient, but love shall endure…

#25

Good day,

I faced similar problem. In the beginning I used DHT-22 connected to pin 7 and it was working but for no reason it stopped after a while. I tried using pin 3 instead of pin 7 and it worked fine then.

#26

Hello and thank you for the reply,

I FINALLY found the problem. It is with the version of the library that does not work. Only the older ones do work.

Someone messed up when they updated the library.

Thanks