Dest already exists. The error has no formatter, which is a bug


#1

how can i solve the problem.

Error
dest already exists.
The error has no formatter, which is a bug. Report the issue to XOD developers.


#2

hi, when does the problem occur? Can you upload the log?


#3

i use the board(arduino uno ),but the software can’t search the board(that time is use the version 0.25.1) .i think the problem is maked by software.so i uninstall the version 0.25.1.then i install the 0.24.1,but i can’t search the board too.after that i can’t not find out the XOD 0.24.1 in procedures and functions.i don’t care it install the 0.25.1 again,then it show this Error in XOD 0.25.1.

i try to use my friends computer with his board(arduino uno),it can be search the board and upload.maybe my board have some problem.


#4

Do you have the Arduino IDE installed? if you can see connection to the board, the problem may be the installation of XOD, otherwise it is the board or the drivers


#5

the arduino IDE can connect the board.maybe the problem is made of repeat install the XOD. a few days ago,i can use XOD 0.25.1 upload to another board.


#6

Install Everything search as admin, search for XOD, and move all to a backup folder. Install again.


#7

have solved.thanks:smile:


#8

i have another problem now.the XOD show all the board not install.how can i download and install it?


#9

I do not understand well but try this

UPDATE


#10

If a board is shown as “(not installed)”, just go on and hit “Upload.” The IDE will offer to install the missing packages.

The UX is counter-intuitive a bit and yet to be fixed. We tried to deliver the feature sooner, thus the result.


#11

BTW, what @cesars shows is a tool to upgrade the already installed packages to their newest versions if there were new releases since their installation.


#12

have already been solve.thanks