Compiler hangs when using hardware uart-x output nodes on mega 2560 !?

Compiler hangs when attempting to run Waylan-gps example 1…this had worked fine til about a week ago.
I’ve tried uninstalling & reinstalling XOD ide to no avail. I have tried compiling the uart-1, uart-2, & uart-3 by themselves and the compiler would hang. I tried leaving out the uart output node and then it compiled !!!

HELP !!! How do I fix this problem ?

Do you have the correct board selected to download to?

Is there any compiler output? Without knowing where it gets to in the processes, it would be very hard to help you.

I’ve just done a quick test with an Arduino Mega and a NEO6MV2 UART GPS module. I’m running XOD on a mac. Working as normal for me:

Yes…example-1 worked well on the meg 2560 multiple time over a 2 week period…then, last week it hung up with the small green bar came on indicating compiler started…then, suddenly the green bar dropped out with no error messages…and, when attempting to upload again, a message came up indicating a prior program was busy.

This problem came up when I was attempting to use uart-1 with LoRa & uart-3 with GPS…where I was wanting to send GPS corrections from a “base” mega 2560 to a mobil mega 2560 via LoRa…basically, achieving RTK with 2 mega 2560s.

No error messages…small green bar would appear for about1 sec (indicating compiler had started)…then, suddenly the green bar would drop out, with no messages. And, when attempting to upload again, an error indicating the prior upload was busy.

I have reload the 2560 board in arduino with no effect in XOD…as I thought the board had been corrupted somehow.
Is there something I’m supposed to do in XOD to reload the 2560 board ?

Would you be able to share your patch? I want to see if I can replicate the issue. Which OS are you running: windows, mac or linux?

When you uninstalled/reinstalled XOD, did you delete your personal xod directory (C:\Users\username\xod or /Users/username/xod or /home/username/xod, depending on platform)?

windows 11…how do I share a patch ?

used the XOD uninstall exe

didn’t delete the other file…I could try that.

Save your project as a single file “xodball”. From the File menu, select Save As. Then add “.xodball” extension to the project name. You should be able to upload the xodball to the forum.

testlora.xodball (4.4 KB)

I think I have upload “testlora” to the forum…not sure.
When trying to run this xodball on my laptop, it will simply hang the compiler with no green bar and no error message…unlike when running your example-1 which will show the green bar for about a second and then drop out.

OK, it looks like you’ve modified the built-in uart-1 node, as I see the following error on your testlora patch:

To restore the original uart-1 node, close XOD, then browse to your personal XOD library directory. On windows this will probably be C:\Users\username\xod\__lib__

xod\__lib__ contains libraries you have installed using the library manager. You will see a directory in xod\__lib__ called xod which contains any core libraries you have modified. If you delete xod\__lib__\xod, you will remove any modified core nodes. Then, on restarting XOD the original built-in nodes will be restored.

I noticed another issue in your lora node. In your C++ code you call Serial.println. The first serial interface is already being used by XOD for debugging. Instead of sending messages using Serial.println, you should send them to a watch node.

I’m not sure if the above advice will solve your problem, but it should get you a bit closer to a solution.

ok…I’ll give that a try.
the Serial.println was put in when output to watch node didn’t work.
I believe you are on to something as several hours I renamed C:\Users\dave bowden\xod\ to …xod092023 and then restarted XOD and rebuilt testlora with uart-1 and it compiled for the first time in more than a week !!!

of course, it was missing all my other files…I’ll go through the procedure you described.

That did it !!! WaylanGPS example-1 now works again…as well as testlora !!!


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.