Windows 10 Error Message Installing XOD IDE Setup 0.38.0


Hello, you do not have administrator access so you cannot install from C:\ … change the file to desktop or try run as administrator

1 Like

I called myself doing that, but I’ll try it again. Thanks.

Stupid question #1 of a million: Do I have to have an Arduino already plugged in to install this?

Okay, I found it… I had to install the Arduino IDE FIRST. It is a requirement of the XOD setup and it is assumed to be loaded. I hope this helps others who install software independent of other requirements or are too busy (or lazy) to dig further and read the instructions. Thanks @cesars for your help, but that message is misleading.

no, you don’t need arduino. But you must use the original path given by the installer and run from downloads or desktop.

I have XOD installed and I don’t have the Arduino IDE installed.

@cesars Thank you again for your quick reply and assistance. I tried giving myself security to the folder and even changed the attributes from r/o to r/w on the file and folder. Nada…

After I installed the Windows 10 Arduino IDE app, I tried again and it worked. I can’t explain it other than my observations. Perhaps something got out of sequence or a window was hidden, but it appeared to work after the Arduino app was installed.

In the spirit of helping others, I hope this helps somebody else like me.

Yes, but what happened is that the IDE executed from another directory wrote some file or necessary key. You don’t need the Arduino IDE. Windows blocks installer executions from certain directories for security reasons and sometimes does not work even with privileges used

Once I checked the properties page for the folder and the file and granted R/W access, I ran it as Administrator. It is possible it took a while and was running in the background while I thought I needed the Arduino IDE installed. So, C:\XOD is where I installed it from.

Incidentally, not to be a “show off” (because I have obviously shown my soft underbelly here), but I have been a computer programmer since 1981, used to manage a computer store for the first ever IBM clone computers (Eagle Computer), and am now a Software Development Supervisor (which means I write a lot less code these days and do more “cat herding” than anything else). While I know that Microsoft makes changes for security purposes, I can usually manage my way around.

I am not being critical of XOD’s IDE, but this is the first software product I have downloaded that gave me errors like the one I described. I first tried to install it from my downloads directory (or Folder in the post-millennium vernacular) and it gave me the error message.

Again, @cesars, I really do appreciate your rapid assistance. I didn’t check, but is there an installation guide somewhere to be found?

@cesars I will verify what you are saying above when I install the XOD IDE on my laptop, which is also running Windows 10 Pro, this weekend. I will leave the Arduino IDE off of the machine, set up the attributes of the folder and setup file, then run as Administrator to see if we have a solution. Sound like a plan?

If I don’t doubt his ability, I’m more of a trial and error experiment, and well, it’s years of testing maybe 20 :smiley:

I recommend that you install without privileges from the desktop or download folder, you should not have problems.

I don’t know right, but I think the root directories of C; or another disk give problems in some executables.

You can create the same directories and test, it may also be that some antivirus will block the execution, but I don’t think so.

Protecting the root is pretty obvious, but a first level folder created by the Administrator of the machine shouldn’t be a threat unless there is somebody who has hijacked the user account, which can happen, so I understand.

Most programs install to the normal Microsoft Programs folder, but many utilities and command line tools in the open source community do not. I get that too.

My point is that any installer of a program should give more explicit errors when they can’t find a file, device, or have no rights.

Yes I understand, but from the warning I see that it is the system that alerts and does not allow the installer to start, any warning of the installer is blocked.

After failing to run a second time from the C:\XOD folder, I copied the setup program to the Desktop and ran it from there as Administrator. It ran fine and installed properly. I think we can close this out and mark your recommendation as the solution. Good job @cesars! Thanks again for your quick assistance.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.