Uploading to Raspberry PI Pico


Did anyone try to upload a project to a raspberry pi Pico?
I installed the required packages, my RPI pico works fine (i confirmed by uploading a program through Thonny, in order to make sure that it works before trying it with XOD). I made a simple blinking project, it compiles properly but fails to upload with an error message.

Am I missing something?

What is the error message?

This is the error code:

Error during Upload: uploading error: uploading error: exit status 1

Upload failed
Command Process exited with code 1
Make sure the board is connected, the cable is working, the board model set correctly, the upload port belongs to the board, the board drivers are installed, the upload options (if any) match your board specs.

I tried with 3 Pico’s (2 are brand new), 2 usb cables (1 is brand new) but same error, although they work fine when I test uploading a code over Thonny


What upload options are you using? (board & port selections) I’m not seeing any Raspberry or Pico options, and I didn’t think it was supported…

When I click on Deploy>Upload to Arduino… I get the prompt to select the board and the port. In the board menu there are many boards (not only Arduino), when I chose to upload into the Raspberry Pi Pico for the first time it asks me to accept installing the required packages, then it compiles and starts the upload. But it exits after few seconds with the error that I reported.

Can anyone please confirm if they have tried with a Raspberry Pi Pico and what was the outcome. At least for me to know if it is expected that it doesnt work with RPI Pico, or that it does work but there is an issue that I need to fix.

I achieved.

1 - install the latest arduino IDE, install the raspberry pico related libraries, do a test with the led blink, make sure the led is blinking.

2- close the arduino IDE.

3- Open the XOD.IO IDE, make a very simple program just to flash, try to deploy and debug, choose the board (board model: raspberry Pi Pico and the port it is installed on), no need to press the bootsel button.

4- if everything goes well, XOD.IO itself will download some packages.

See the deploy message that mine generated:

rp2040load 1.0.6 - compiled with go1.16.2

Loading into Flash: [ ] 0%
Loading into Flash: [= ] 4%
Loading into Flash: [== ] 8%
Loading into Flash: [=== ] 12%
Loading into Flash: [===== ] 17%
Loading into Flash: [====== ] 21%
Loading into Flash: [======= ] 25%
Loading into Flash: [========= ] 30%
Loading into Flash: [========== ] 34%
Loading into Flash: [=========== ] 38%
Loading into Flash: [============ ] 42%
Loading into Flash: [============== ] 47%
Loading into Flash: [=============== ] 51%
Loading into Flash: [================ ] 55%
Loading into Flash: [================== ] 60%
Loading into Flash: [=================== ] 64%
Loading into Flash: [==================== ] 68%
Loading into Flash: [===================== ] 72%
Loading into Flash: [======================= ] 77%
Loading into Flash: [======================== ] 81%
Loading into Flash: [========================= ] 85%
Loading into Flash: [=========================== ] 90%
Loading into Flash: [============================ ] 94%
Loading into Flash: [============================= ] 98%
Loading into Flash: [==============================] 100%

=== Done ===

I put together a very simple program, just to flash the led and it works normally.


Sandro (I am from Brazil)

1 Like

Thank you Sandroluisk for your reply!
After many attempts of uninstall/install I could finally compile and upload the blink patch to Pico.
The deploy message that I get is similar to yours, but the led doesnt blink. I tried different ports with different time settings in the square wave but still nothing. The pico works fine when I programm it through Arduino IDE or if I program it in python for the same simple exercice.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.