Unable to upload to Arduino Uno on Ubuntu 17.10


#1

error occured during uploading. Error: permission denied. can not open /dev/ttvACN0

Using Arduino Uno. Trying to upload a blinking sketch. using a desktop client of xod on Ubuntu 17.10. Anybody has faced similar problem before? Thank you


#2

The user you’re logged in with has no permissions to work with serial ports. I think it’s default for new users in Ubuntu. See: https://askubuntu.com/questions/58119/changing-permissions-on-serial-port

Let me cite the solution:

The issue with the permissions for /dev/ttyACM0 can be permanantly solved by adding yourself to the dialout group. You will have to logout and then log back in before the group change is recognized.
You can do this with sudo usermod -a -G dialout $USER


#3

Thank you victor, it worked as per your advise. I am having similar problem while using xod on Windows 10. Do you have any advise for that too. I am a blogger. Intend to make a new series of video tutorial on xod for my viewers. Need to work on Windows too. I am adding screenshot of the error message below. ( Windows 10) says at the bottom of the screen - unknown Error code 121


#4

Hi, After a few tries, I restarted my computer and the problem resolved on its own.