Tutorial is not working for me

My son and I have been trying to find our way into all of this but we have had very little luck so far.
Following along with the tutorials we got as far as the LCD before we ran into trouble. Now after 4 nights of reading/researching and learning we have still not gotten anything to display on the lcd.
we are using a Sun Founder 16x2 I2C.
It has an address of 0x27.
We are using the desktop version of xod.
originally we thought maybe the knock off Uno was the problem so we are now using an actual Arduino Uno
We have tried using the A4/A5 as well as the SDA/SDL pins
We have tried a number of internet research based ideas such as. running a scan to determine the address. this confirmed the address as 0x27.
We have tried a myriad of pull up resistors.
I cant help but think that we are missing something very simple, though right now it is alluding us.
Any advice?
Here are the photos to show what we have put together:


Success!!! We figured it out while looking at these pictures. Now it works great. Can anyone guess what was wrong???
“Sometimes”, shaking head as i look at the ground, “Sometimes…”

hi, I think you are using silumation instead of debug

yes yes, but we did try uploading and it would upload fine. that was not the issue, hint…missing something that is in every breadboard schematic ever made…

I cant keep secrets, it was a ground wire. A GROUND WIRE! Oh god, how in the heck?..

Yeah the LCD was perfectly pinned to the breadboard…, but that side of the breadboard does not have a ground wire to the common ground going to the UNO.
My son and I are still laughing at ourselves. we went soooo far into internet research trying to figure this out… and then looking at the pictures it was like duh wtf!!! seriously? you just got to laugh.

1 Like