Question about the array

Is it possible to somehow make an array not from 1 to 100, but from “A” to “Z”?

A single character is a byte. You can use u8-to-number to force conversion to number, then subtract 65 (byte value of ‘A’), or use map-clip and adjust max values to match size of your nth-input array.

after u8-to-number all the time the value is zero:

Looks like you are using tweak string instead of byte. That will return 0.

tweak byte

When I use simulation:

2 possibilities:

  1. result is different when using Arduinio
  2. Debug is not yet active if you are downloading to Arduino board. Have you tried hitting reset button on Arduino after downloading has completed? I have issues that XOD is not ready to start debug when Arduino tries to start it immediately after download. Reset of Arduino after download resolves this issue.

I just tried with Arduinio Uno. When debug session didn’t start after download, watch node continued to display “watch” instead of “0”. After Arduino reset, watch node displayed 65.00 just like in simulation.

Ah…if I change the tweak node during debug, watch changes to “0” and stays that value no matter what I change tweak to. This would seem to be a bug… Same thing happens with simulation and download to Uno. It only displays correctly if tweak node is set before doing download/simulation.

I started debug.

then i reset.

value he showed right (at least it showed). then i changed the value to ‘x’ and again shows zero.

I reset it again and he showed me the value that was on ‘b’

as if watch remembered the value at the beginning of the simulation and with any letter shows the value of the first letter (b)

I think this problem is the same thing that happened to my previous month.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.