Problem installing xod on debian linux

Good day,

I downloaded the latest version of xod for i86 based linux whic is “xod-client-electron-0.29.1.x86_64.rpm” (rpm package).
On the linux terminal I used alien tool to convert rpm to deb but unfortunately I got error message “xod-client-electron-0.29.1.x86_64.rpm is for architecture amd64 ; the package cannot be built on this system”

The command used
root@debian:/home/omran/Downloads# alien -d xod-client-electron-0.29.1.x86_64.rpm
The reply was
“Warning: Skipping conversion of scripts in package xod-client-electron: postinst postrm
Warning: Use the --scripts parameter to include the scripts.
xod-client-electron-0.29.1.x86_64.rpm is for architecture amd64 ; the package cannot be built on this system”

Did any of you faced this problem? Did I miss something in the installation procedure? I appreciate your help.

I don’t know much about anything to do with XOD but I was always aware of, and used, the deb version - so I am assuming you did not see that in the options list.

I took a screen shot to make sure I was not dreaming and doubt I can post a picture here - if I can I will - otherwise please look again at the available file types - it is there - an original deb install file.
XOD%20download

Deb version is used on linux running on amd processors. The rpm version as mentioned on the page is for working on x86 processors.

The issue is after converting the rpm version to deb using alien tool the result is an amd deb version while it should come up with x86 deb version which is not happening

My PC is running debian for intel 386 processor so the installation process stops

I hope someone else can chime in here! It has been my understanding that the x86 has little to do with Intel specific processors (or if it does - perhaps legacy systems) - what I have is an I7 Intel Laptop and I used the deb version and it installed fine - in fact I have used that version for all my virtual machines, all variations including Debian derivatives (MX17 and 18.xx), and Solus, and Arch based - all work the same… have you tried the online DEB version - and if you have what is your hardware and what Linux are you using - that might help others much more knowledgeable that me to see a real problem and could give you specific instructions. Cheers

I am fairly confident you did not really mean you were using an actual 386 processor - if you are then this could be an issue - as far back as I can remember 20 years or so, we needed to also have a 387 processor or it would not run any CAD or Math software.
If taken literally then I am going to guess that this is a piece of history and could be worth a lot of money if it still operates and you might sell it to a collector who might give you enough money to buy a 5 -10 year old computer that will run modern software… just my thoughts - don’t take anything I say seriously ! Cheers from Australia :slight_smile:

I have also I7 processor. I tried installing the dep package using “apt install” command but received the same error.

I appreciate sharing the procedure you have followed and the list of command lines.

OK - it would seem you have an unusual problem. I know this forum can be a little slow in responding to questions from newbies (like me) and so I thought I would at least say something to you - and hope that someone else would see some activity and chime in - what I have needed to do in other CAD forums is to specify exactly what my environment is - i.e. in Linux - what distro, and what version as well as hardware etc that it is running on. I have never tried Actual Debian (i.e. pure Debian) as I have been led to believe that it is more difficult than the polished and curated versions such as MX or the hundreds of other Debian derivatives (I suspect the pure version of Debian is for more experienced Linux users). If using pure Debian you could try installing a derivative spin in a virtual environment to test it out and then delete the whole machine if someone solves the issue for you later! Cheers

same problem on a pentium processor with ubutu 32 bit
strongly wish to use xod
impossible to achieve
cheers
gmn

Which version of Ubuntu are you having the problem with - if no one else comes to your assistance, I can try to install a virtual machine and see how the install progresses - what are the errors you are getting and what messages are displayed ? This would be useful information for any one else looking at your post, otherwise we would all be guessing. As I have mentioned previously - I am not the knowledgeable with XOD or Linux, but if no one else tries to help - I am happy to have a go at installing with as close to your versions and hardware spec as possible. I remember looking to see what the hardware requirements are for XOD and have not found that - most software does have this information and I hope if it does not yet exist - it will soon for clarity and configuring a machine just for XOD. Be as specific as you can be with your system configuration so I can emulate it in a virtual machine (I would be using Virtual Box 6.xx)
cheers

As I am aware, XOD is only available for 64-Bit systems. It cannot be run on 32-Bit systems.
There has been some progress running XOD on 32-Bit Windows but I do not know if there’s an option for Linux.
Here’s the link if anyone is interested : XOD on Windows 32-bit

1 Like

Many thanks for your initiative.

Actually the problem appeared on Debian 9.9 not Ubuntu. I made more deep analysis and discovered an incompatibility issue between my Debian system which is 32 bit version and xod which is 64 bit package. I changed to Debian 64 bit version and then the error disappeared. I installed XOD successfully and it is working fine.

1 Like

I made a mistake in installing ubuntu as I used a 32 bit version on a 64 bit pc. So reinstalling everything solved the issue, for me. But previously the package labelled 32 bit didn’t install on the 32 bit system. The error was about the fact that the package
assumed to be a 64 package on a 32 bit system. No way for me to reproduce the issue. Thankyou for the help offered.

Grazie

gmn

I forgot to specify that was ubuntu 18.04

gmn