_Node sd card Error

Hi,

I TRIED TO USE THE SD CARD NODE AND GET THE FOLLOWING ERROR:

How can it be solved?

Thanks

Take a look at this post:

It raised an error, so it’s not a problem with the memory as in the mentioned topic.

Let’s look at the node description. It tells us that there may be a few possible errors:

  • Can’t open a file.
    SD card should be formatted in FAT16 or FAT32 format. Also, it uses a short 8.3 file names, so it converts long names like foobarbuz.txt to fooba~1.txt. So, avoid using file names longer than 8 characters.
  • Initialization failed, or no SD card.
    Initialization can fail if you specified a wrong CS port or your module is broken.
    Check that the SD card is inserted properly.
  • Can’t write data to the SD card.
    For example, the SD card is locked for writing. Check the small switch on the side of your SD card.
    Also, you can try to write something in this file using your PC.

I hope it will help :slight_smile:

Maybe frequency of writing to SD is to high?

I just finished a project that used the SD card log node. The key for me was making sure that the SD card board was connected to the SPI pins. The SPI pins on the Uno are 11,12 and 13. The SPI pins on the mega are 51, 52 and 53. I used 54 for the chip select pin on the mega and 10 for the Uno. I also used the SD card log node on an ethernet shield that had an SD card. It worked flawlessly. I wrestled with getting the SD card node to work for a long time, I feel your frustration. I can testify that the SD card node does work however.

If you want the clock to pulse every quarter second you need the RST on never not boot.