New MIDI Nodes: awgrover/midi


@dox and I created a few MIDI nodes. Use “Add Library” to get them: awgrover/midi

We’d love to see them used, get feedback, and fix any problems. They’ve only been tested lightly.

Right now, you are limited to the default MIDI serial port (Serial on most Arduino’s, Serial1 on Leonardo, Due). I’m not sure how to expose multiple serial-ports. Also, I’m pretty sure “thru” doesn’t work.

  • note starts and stops
  • control-change
  • program-change
  • bank-program-change, aka “bank-select”
  • note-button press starts, release stops

I have the code up on You can give feedback there, or here.


Hello awgrover!

After updating to 0.17.1 and updating Arduino IDE to 1.8.5 I tried to test your new MIDI-nodes.

Forty Seven Effects Library is installed via Sketch Menu --> Add Library

arduino ide

Folder is copied to XOD library folder:

kopie lib

New awgrover/midi nodes are installed.

But I got only error messages during uploading:

Unfortunately I can not copy the whole text so I made a screenshot.

Any idea what’s going wrong?


That’s because a dot terminating pin label No.. Pin labels are not escaped anyhow currently. So, I suggest to rename No.No



I tried to rename the node pin but this will not fix the problem:

Also after changing the note node:


thx for this one … !!!

control-change has in the line 37-39 (inside the node) old, not declared variables (just naming syntax) , the compiler goes wild at this point ::

37: auto channel = getValue<input_channel>(ctx); /// should be:: input_Ch
38: auto controller_number = getValue<input_controller_number>(ctx); // should be :: input_CC
39: auto control_value = getValue<input_control_value>(ctx); //// should be :: input_Val

and the debug section is recomend to comment out , it gives lot of data in the midi channel…

i edited the nodes code for myself , but you could update this one globally.

THX !!


I finally repaired this. It was pure sloppiness on my part. It compiles now. I would appreciate feedback on whether it actually works.

awgrover/midi v1.3.2

I added a link to the installation steps, which are a bit of a pain.


Again, I was sloppy. Fixed. v1.3.3. @microsoundfield, thanks for catching that.