LiquidCrystal.h is not found

Hi All,
I created solar-water-pump-cotroller project last year for a solar heating system for an inflatable hot-tub. It was written using IDE 0.36.1 and all works well, but I now need to make some amendments and change some variables. When I try to create a simulation using 0.36.1 and a version of my project which enables this to be done easily, I get the error message in the title of this post. See attached screenshot for complete message.

The project was created entirely using standard nodes, i.e. no external libraries, so I am baffled as to why this is happening as both my simulation version and the final loaded version worked without any such errors.

I have downloaded IDE 0.38.0 and tried again but get the same error message.

Any help would be greatly appreciated.

Complete system V4.1.2debug.xodball (71.9 KB)

https://xod.io/docs/guide/wrapping-arduino-libraries/
This can help.

Thank you Danya for getting back to me so quickly. I did check this out before posting but I know nothing about programming in C++, so was hoping there will be a solution I can deal with.

Equally, I need to understand why that library has dissappeared since I first created my project.

Try downloading it to the board through debug mode, not through simulation.

You can’t use simulation mode with hardware (like LCD). The simulator has no way of dealing with that. You can replace LCD with watch node to test the rest of your code using simulation, but other hardware (like buttons and sensors) need too be replaced also (tweak nodes can be used to stimulate input).

Hello Gweimer,
Thank you for your response and yes, I found a previous post of yours on the same topic. I then realised my mistake and having removed the display bits from the simulator version everything worked OK. Lessons learned the hard way are never forgotten! :wink:

Thanks for your interest Danya. The answer lay in Gweimer’s post below. (above!) :grin: